rollover_phone_to_print.pl sends new event ids to eg-pbx-mediator ack_failures

Bug #1650807 reported by Josh Stompro on 2016-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.11
Low
Unassigned

Bug Description

EG 2.10.6

I'm attempting to use the rollover_phone_to_print.pl script to collect failed phone calls and move them to a new event_def.

http://git.evergreen-ils.org/?p=Evergreen.git;a=blob;f=Open-ILS/src/support-scripts/rollover_phone_to_print.pl;h=6956283fbefb8fb742fe96384d14e8a394728af6;hb=refs/heads/rel_2_10#l76

The events are collected and moved ok, but the ack_failures call isn't working. The failed call files don't get moved. I believe this is because the script is sending the new list of event ids to ack_failure, not the original list of failed events. I think the wrong variable was chosen when building the list of finished events.

Fix on the way.
Josh

Working branch at
user/stompro/lp1650807_rollover_phone

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1650807_rollover_phone

I'm not sure if release notes are needed or not. I doubt that anyone else is using this script since this bug makes a major part of it not work. So if someone is using it, they probably already fixed this.

Another thing that might be an issue is that this script needs to be edited directly to work. So any updates are going to overwrite customization. But again, I wonder if anyone is using this in production?

Josh

tags: added: pullrequest
Galen Charlton (gmc) on 2017-05-17
Changed in evergreen:
milestone: none → 2.12.2
status: New → Confirmed
importance: Undecided → Low
status: Confirmed → Fix Committed
Galen Charlton (gmc) wrote :

Change works for me. Merged to master, rel_2_12, and rel_2_11. Thanks, Josh!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers