web client: initials are not stored when adding copy notes

Bug #1643927 reported by Kathy Lussier
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned

Bug Description

Tested on a local, master system and on webby.

When adding a copy note for an org unit that has the require initials setting enabled, the client does indeed require that the user enter initials. However, those initials are not stored in the database. Subsequent retrievals of the copy note, therefore, will not display those initials.

Revision history for this message
Beth Willis (willis-a) wrote :

Tested on local system (EG 2.12.2)

I have confirmed that when adding a copy note and entering my user initials, the initials are not saved in asset.copy_note.

Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Patch pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1643927-copy-note-initials

From the commit:

Fixes thinko in copy note staff initials tracking. Offloads the formatting of the copy note to egStrings. Adds the workstation org unit to the initials block a la the XUL client.

This does not add the create date to the initials block as with the XUL client, because the create date is part of the note. Instead, we now display the note create date in the copy note display form.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0-beta2
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Cesar V (cesardv)
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Revision history for this message
Cesar V (cesardv) wrote :

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/berick_lp1643927-copy-note-initials_signoff

This works for me. I can see the initials display in the note, put at the end in as [ <init>@<org_unit> ]
Sign-off branch above.

Revision history for this message
Cesar V (cesardv) wrote :

Thanks Bill!

Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Galen Charlton (gmc)
tags: added: signedoff
Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_12. Thanks, Bill and Cesar!

I note (or well, emphasize) that choosing to not include the date in the initials block means that there's a minor discrepancy between XUL and web staff. If this turns out to be a big deal for anybody, please speak up.

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers