Web Staff Client - Missing Receipt Templates and Actions

Bug #1642016 reported by Terran McCanna on 2016-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

While testing on the 2.11 web client I've discovered the following missing receipt templates / functionality:

holds_on_bib (now Holds for Bib Record - but gives an errror when I try to pull it up in the new interface)

item_status (no receipt template and no equivalent print functionality in the web client)

transit_list (no receipt template and no equivalent print functionality in the web client)

items_out (this functionality is available, but the template doesn't appear in the dropdown)

checkin (this functionality is available, but the template doesn't appear in the dropdown)

in_house_use (no receipt template and no equivalent print functionality in the web client)

holdings_maintenance (no receipt template and no equivalent print functionality in the web client)

renew (not sure where this is used in the xul client - is it no longer necessary?)

holds (not sure where this is used in the xul client - is it no longer necessary?)

******************

I'm also including the following information regarding the rest of the templates here just for future reference:

Templates That Have Already Been Replaced:
checkout (now Checkout)
bill_payment (now Bills, Payment)
bills_historical (now Bills, Historical)
bills_current (now Bills, Current)
holds_for_patron (now Holds for Patron)
holds_shelf (now Hold Shelf List)
holds_pull_list (now Hold Pull List)
hold_slip (now Hold Shelf Slip)
transit_slip (now Transit Slip)
hold_transit_slip (now Hold Transit Slip)

New Templates in the Web Client that were not in XUL:
Patron Address
Patron Note

Offline Client: (Not yet built, so no templates yet)
offline_checkin
offline_renew
offline_inhouse_use
offline_checkout

tags: added: printing
Kathy Lussier (klussier) wrote :

To answer a couple of your questions above:

The renew receipt template was used for the Renew Items screen in the staff client. I don't know how much use it gets, but I'm guessing it's useful to have on the occasions when patrons get their items renewed at the circ desk.

The holds receipt template is a vestige from the days when there was one holds template to govern all of the holds interfaces. The distinct templates for each individual holds interface didn't arrive until around 2.2 or 2.3. Since we do have those distinct templates now, I think the holds receipt template can go.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Terran McCanna (tmccanna) wrote :

Thanks, Kathy! I forgot that Renew Items screen was even there - I'm sure some staff use it, but I always renew from the patron's account. I just tested it from there and the printing works, but there is not a template for it listed in the Print Template interface.

Kathy Lussier (klussier) wrote :

Adding a note that I believe all of these templates have been added since the original report with the exception of holdings maintenance.

Offline templates are also still unavailable since offline functionality has not yet been added.

Andrea Neiman (aneiman) wrote :

Noting for the record that offline templates are included in the branch for offline circulation & will be merged when Offline Circ is merged.

Terran McCanna (tmccanna) wrote :

All print template are present in 2.12, so closing out this bug.

Changed in evergreen:
status: Confirmed → Fix Released
milestone: 3.next → 2.12.5
milestone: 2.12.5 → none
Kathy Lussier (klussier) wrote :

I still don't see one for Holdings Maintenance. Do you think it's best to open a new bug report for that one?

Terran McCanna (tmccanna) wrote :

You're right - Holdings Maintenance is still missing. Switching back to Triaged.

Changed in evergreen:
status: Fix Released → Triaged
milestone: none → 3.next
Andrea Neiman (aneiman) wrote :

I'm going to open a new bug for the Holdings Maintenance template.

Changed in evergreen:
status: Triaged → Fix Released
Andrea Neiman (aneiman) wrote :
Andrea Neiman (aneiman) on 2017-10-06
Changed in evergreen:
milestone: 3.next → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers