web client: error when trying to pay by credit card

Bug #1622696 reported by Kathy Lussier
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
High
Unassigned

Bug Description

Seen on a 2.10 system with the web client and on webby.

If you attempt to pay by credit card in the patron Bills interface, you will get an error message that says "Event 2000:BAD_PARAMS -> Invalid parameters were encountered in a method. Need approval code."

The system should be generating a popup to allow staff to enter more information regarding the credit card transaction where the approval code can be entered.

The payment will fail. However, if the "Receipt on Payment" option is selected, the system will generate a receipt showing that the transaction succeeded.

Revision history for this message
Andrea Neiman (aneiman) wrote :

Confirmed on 2.12 webby

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Terran McCanna (tmccanna) wrote :

Confirmed this is still broken on 2.12. I bumped up the importance to High because it's a daily requirement for a lot of libraries.

Changed in evergreen:
importance: Medium → High
Andrea Neiman (aneiman)
Changed in evergreen:
milestone: none → 3.0-beta2
Revision history for this message
Galen Charlton (gmc) wrote :

A fix for this won't be available for beta2, but I'm doing some duck-string-pulling to arrange for a fix by the RC.

Revision history for this message
Bill Erickson (berick) wrote :

Something tripped my duck alarm... Grabbing.

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

CC dialog pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1622696-staff-cc-payments

Includes 2 commits.

1. Minor egPromptDialog repairs

2. Credit card dialog. This commit also includes fixes to how the flow of events leading up to a payment happen, including verifying warning-level payment amounts, annotating payments,and collecting credit card data. It's now possible to perform any combination of these.

I have tested collecting data for out-of-band credit card payments. I have not tested creating credit card payments via Evergreen credit card processor, though I believe it should work.

tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

I've tested both out-of-band payments and in-band payments (via AuthorizeNet's sandbox) and it works for me. I've pushed a signoff branch + a follow up that drops the credit card type from the out-of-band payment options (since, per bug 1474051, we don't store it) to user/gmcharlt/lp1622696_signoff.

tags: added: signedoff
Galen Charlton (gmc)
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Revision history for this message
Mike Rylander (mrylander) wrote :

WORKSFORME. Thanks, Bill and Galen! Picked to master.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers