Web staff client pre-catalog entry shouldn't respond to the enter key (at least until all fields are filled in)

Bug #1622364 reported by Jane Sandberg
2
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

On the webby demo server, we tried to create a pre-cataloged item. However, we made the mistake of scanning the ISBN from a book, rather than typing it manually. Our barcode scanner, like many libraries', is set to add a carriage return to the end of each barcode it scans. However, the web client interprets this to mean that we are done entering information about the item, and it saves the item and returns us to the checkout screen. If we are entering the fields in order, this means that if we scan the ISBN, we never get a chance to select a circ modifier.

This is not an issue in the XUL client, since the enter key does not cause the precat item screen to save and close.

Revision history for this message
Andrea Neiman (aneiman) wrote :

Confirmed in 2.12 -- as long as there is at least 1 character in the "title" field, a carriage return at any point will save & close the pre-cat window.

Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier)
Changed in evergreen:
importance: Undecided → Medium
Revision history for this message
Galen Charlton (gmc) wrote :

Some options I see include:

1. making all fields required (but not ever item will have an ISBN or equivalent identifier, nor do all libraries necessarily using circ modifiers)
2. disabling submit-on-enter only when focus is in the ISBN input
3. disabling submit-on-enter for the entire form, obliging the operator to mouse or tab over to the submit button

#1 seems like a non-starter, but preferences regarding #2 and #3?

Revision history for this message
Jane Sandberg (sandbej) wrote :

#2 seems like the least intrusive option. As long as it is documented somewhere, I doubt it would cause too much confusion.

Revision history for this message
Kathy Lussier (klussier) wrote :

+1 to #2

Revision history for this message
Andrea Neiman (aneiman) wrote :

agreed on option #2

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.0-beta2
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Cesar V (cesardv)
Changed in evergreen:
assignee: nobody → Cesar V (cesardv)
Revision history for this message
Cesar V (cesardv) wrote :

This fix worked for me Bill, thanks. Though, full disclosure, I did not test using an actual barcode scanner.
Just copy pasting an ISBN and hitting enter on my keyboard.

Signoff branch here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/cesardv/berick_lp1622364-precat-isbn-form-nosubmit_SignOff

Changed in evergreen:
assignee: Cesar V (cesardv) → nobody
Galen Charlton (gmc)
tags: added: signedoff
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Works for me, and pushed to master. Thanks, Bill and Cesar!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Revision history for this message
Jane Sandberg (sandbej) wrote :

Fantastic! Thanks, Cesar and Bill!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers