webclient: Copy status field missing from column pickers

Bug #1621178 reported by Kathy Lussier on 2016-09-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

The copy status field is useful to display in many client grids, but I'm not seeing it as an option for most grids in the web client. Most notably, it's not included on the Item Status page (one would expect to see the status on a page named "Item Status"), but I also didn't see it as an option on the patron's Items Out screen, the Checkin screen, and holds interfaces (there is a status for the hold, which is a different thing.)

Kyle Huckins (khuckins) wrote :

I've dug around for a few situations where the Copy Status picker is available, and it does show in the copy buckets. After taking a look at the differences between the grid used in the copy buckets view and the patron holds screens' implementation, I noticed that the copy buckets grid was specifically using the 'acp' class, whereas the holds, checkout, and items out screens don't use a specific fieldmapper class by default, and instead takes bits and pieces from various classes as necessary. To that end, I've attempted making use of (in items out)target_copy.status(). This will get us the id, but unfortunately we can't go the next step and grab the string for the particular status id. This might need to be split out into multiple issues for each interface.

Kyle Huckins (khuckins) on 2016-10-25
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Kyle Huckins (khuckins) wrote :

I've added the copy status picker to the following interfaces(all have the copy status picker in the XUL client): Patron Items Out, Patron Checkout, Patron Holds, Holds Shelf, Item View Holds, Item Status

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/khuckins/lp1621178-grid-copy-status-picker

tags: added: pullrequest
Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
Bill Erickson (berick) on 2016-11-16
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.next
Kathy Lussier (klussier) wrote :

Thanks Kyle! I loaded your branch on a test server, and the copy status is displaying in grids as expected.

However, I encountered an odd problem with this code. On the patron and title holds screens, the holds only displayed if they were captured and had a current copy listed. All other, uncaptured, holds did not display. When I removed the branch, all holds displayed again as expected.

In the Concerto dataset, patron 226 is a good record to retrieve to see this behavior. She has four holds, but, once the holds targeter runs, only two are captured. Those are the only two holds that display.

Kathy Lussier (klussier) wrote :

Sorry, I misspoke above. The holds that display are ones that have a targeted copy. The ones in my example were not yet captured.

Kyle Huckins (khuckins) wrote :

Hey Kathy,

I did a little digging into the code, and caught an oversight - the addition to staff/circ/services/holds.js needed to be within the if statement fleshing out hold.current_copy(), not after it. After testing with that change, it should work now that I've made that change and amended my commit.

Dawn Dale (ddale) on 2017-02-20
Changed in evergreen:
assignee: nobody → Dawn Dale (ddale)
Dawn Dale (ddale) wrote :

 "I have tested this code and consent to signing off on it with my email address, [<email address hidden>], and name, [Dawn Dale]".

Changed in evergreen:
assignee: Dawn Dale (ddale) → nobody
tags: added: signedoff
Kathy Lussier (klussier) wrote :

Thank you Kyle and Dawn! I added Dawn's and my signoffs to Kyle's commit and then added another commit that does the following:

* Sets copy status as visible by default on the Item Status list page
* Removes the copy status column from the Checkout page. Since items only appear in this grid after a successful checkout, the expectation is all items in this grid will have a Checked Out copy status.
* Adds the copy status to the holds pull list. This is mostly useful for staff
to see if an item was recently returned, and most likely to be found on the
reshelving cart.

One issue I found, which can be addressed through a new bug if it's not addressed here, is that on holds in interfaces, the Copy Status field displays nothing when the status is available. A status only appears here if it's something other than available.

New working branch at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1621178-grid-copy-status-picker

Galen Charlton (gmc) wrote :

Pushed to master, along with a follow-up to ensure that if the status of a hold's current copy is Available, it will still get fleshed. Thanks, Kyle, Dawn, and Kathy!

Changed in evergreen:
milestone: 3.next → 3.0-alpha
status: Confirmed → Fix Committed
Galen Charlton (gmc) on 2017-06-20
no longer affects: evergreen/2.12
Changed in evergreen:
status: Fix Committed → Fix Released

EG3.1 Copy Status is not available on the check in screen

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers