webclient: Patron registration form and copy editor do not require stat cat fields configured to be required

Bug #1618949 reported by Kathy Lussier on 2016-08-31
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.12
Medium
Unassigned

Bug Description

Patron and copy stat cat fields can be configured to be required. However, the web client is not recognizing that these fields are required.

1. Neither the patron registration form or copy editor provide any visual cue that the stat cat is required.

2. Both forms can be submitted even when required stat cat fields have no value.

Kathy Lussier (klussier) on 2016-08-31
summary: - webclient: Patron registration form and copy editor do not required stat
- cat fields set to be required
+ webclient: Patron registration form and copy editor do not require stat
+ cat fields configured to be required
Billy Horn (bhorn) on 2016-10-25
Changed in evergreen:
assignee: nobody → Billy Horn (bhorn)
Billy Horn (bhorn) wrote :

While working on this card I have noticed on the copies edit page that none of the fields are set to be required is that intended?

Bill Erickson (berick) on 2016-12-21
Changed in evergreen:
status: New → Confirmed
Billy Horn (bhorn) wrote :

For the copies side of this problem it looks like the check for required doesn't work. It seems like the easiest solution would be to configure the copies edit page to accept required arguments. Another option since most of the selections are drop down based and all of the values that need to be required so far just set their first entry as the default value I could try to do the same thing with the stat_cats. If either of these ideas sound good or if another solution would be preferable please let me know how people would like to proceed.

tags: added: pullrequest
Billy Horn (bhorn) on 2017-01-18
Changed in evergreen:
assignee: Billy Horn (bhorn) → nobody
Changed in evergreen:
assignee: nobody → Jennifer Pringle (jpringle-u)
Bill Erickson (berick) wrote :

Removing assignee since it's been idle for a while.

Changed in evergreen:
assignee: Jennifer Pringle (jpringle-u) → nobody
Bill Erickson (berick) wrote :

Pushed a new branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1618949-patron-required-stat-cats

1. Sign-off for Billy's commit, with some tweaking of the commit message for readability.
2. Additional commit to fix a formatting problem in the form introduced by Billy's commit, plus some other minor code formatting fixes (removing commented out code, nesting div repairs, breaking long lines).

Changed in evergreen:
milestone: none → 3.0-alpha
Bill Erickson (berick) wrote :

Opened a separate bug to address the copy editor issue, so that this bug can be resolved with the patron editor fixes: bug #1686459.

Kathy Lussier (klussier) on 2017-05-09
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Thank you Billy and Bill! Works for me. Merged to master and release 2.12

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers