Patron name search - apostrophes

Bug #1613341 reported by Terran McCanna
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

This is a follow up to the fix created for diacritics here:

https://bugs.launchpad.net/evergreen/+bug/1501781

That fix worked great for spaces and other diacritics, but didn't accommodate apostrophes in names.

I'd love to see O'Neal, O Neal, and Oneal all come up as results for the same search. We also have a lot of names with apostrophes in the first names such as T'Andre.

Kathy Lussier (klussier)
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Kathy Lussier (klussier) wrote :

Hyphenation is another place where we would like to see this improvement.

If a patron has a hyphenated last name of Smith-Jones, we would want it to come up when Smith Jones is entered.

Revision history for this message
Terran McCanna (tmccanna) wrote :

+1

Or SmithJones, for that matter.

Revision history for this message
Dan Pearl (dpearl) wrote :

After bug LP#1501781 ("Patron name search should be diacritic-insensitive") was completed, it occurred to some that punctuation should be removed, too.

In MassLNC, this is recorded in http://masslnc.org/node/3049 :

"The current punctuation-sensitive setup is not desirable in any way that I can think of. Lots of false failed searches when library staff search OBRIEN instead of O'BRIEN, SMITH-JONES instead of SMITHJONES, or vice versa. And lots of duplicate accounts as a result.frown

"The inability to add multiple first name or last name fields to a patron record also remains a major functionality present in Millennium Circulation and lost in Evergreen, and leads to many of the same mistakes cited above re: punctuation... Margaret vs. Peggy, Thomas J Smith vs. Jefferson Smith, etc."

This functionality will be controlled by the same user setting as the "ignore diacriticals".

This is not a bug, but an extension to a new feature.

Changed in evergreen:
assignee: nobody → Dan Pearl (dpearl)
Revision history for this message
Dan Pearl (dpearl) wrote :

Any characters matching the POSIX character class [[:punct:]] will be removed from the patron search for family_name, first_given_name, and second_given_name.

This feature will be controlled by the same org setting that controls the diacriticals.

Revision history for this message
Dan Pearl (dpearl) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Dan Pearl (dpearl) → nobody
milestone: none → 2.next
Kathy Lussier (klussier)
Changed in evergreen:
milestone: 2.next → 2.12-beta
Revision history for this message
Kathy Lussier (klussier) wrote :

Thank you Dan! The feature works well, and the additions to the test work well. However, I noticed you edited the 0986 upgrade script to add the new functionality. Instead, you'll need to create a new upgrade script to make the changes to the function and indexes. Otherwise, those sites that have already run the 0986 upgrade script will miss these changes.

Revision history for this message
Dan Pearl (dpearl) wrote :

Urgh. I'll resubmit a new branch shortly.

Revision history for this message
Dan Pearl (dpearl) wrote :
Revision history for this message
Kathy Lussier (klussier) wrote :

Thank you Dan! The upgrade script works for me. Merged to master for inclusion in 2.12!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers