use "Active On" rather than "Activate" as header in TPAC holds tables

Bug #1611815 reported by Galen Charlton on 2016-08-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.10
Low
Unassigned
2.11
Low
Unassigned

Bug Description

The patch for bug 1576502, in addition to changing how fulfilled holds are displayed in the hold history tab in the OPAC my account page, also changed a column heading from "Activate On" to "Activate". Per the following discussion in #evergreen, "Active On" (or maybe a better term?) should be used instead:

[10:47:44] <gmcharlt> kmlussier: around for a quick question?
[10:49:44] <kmlussier> gmcharlt: I'm here now
[10:50:17] <gmcharlt> kmlussier: I'm considering this for backporting to 2.10: http://git.evergreen-ils.org/?p=Evergreen.git;a=blobdiff;f=Open-ILS/src/templates/opac/myopac/hold_history.tt2;h=9aae602297abd647c877db4b58483f9d85bbeb5b;hp=3b8abb93108a8484a90705c0bc800f31e121271b;hb=463ac7ecfe29760e6f520e97e7145813c939ead9;hpb=4c92d095da106a4c2a54bf26e392d5ad57938f4d
[10:50:50] <gmcharlt> and my question is this: whence the /Active On/Activate/ in the patch?
[10:52:14] <gmcharlt> it feels like it snuck in; at any rate, it doesn't seem on point with respect to the bug
[10:52:19] <kmlussier> gmcharlt: Just a sec...it was a long time ago and I need to refresh my memory
[10:52:29] <gmcharlt> sure
[10:54:05] <kmlussier> gmcharlt: OK, it looks like I addressed it in the original bug report where I tried to add it to the Terran's original change. https://bugs.launchpad.net/evergreen/+bug/1275118/comments/3
[10:54:06] <pinesol_green> Launchpad bug 1275118 in Evergreen "Holds history displays canceled holds as active" [Medium,Fix released]
[10:55:08] <kmlussier> gmcharlt: I think I was trying to make it consistent with what displays in the patron's list of current holds. But, you're right, it's not really on point with the bug description.
[10:58:16] <gmcharlt> kmlussier: I'm not a fan of "Activate" as the column heading, as it's a verb, but there's no action one can take in that column
[10:58:44] <gmcharlt> but that said, I don't feel strongly about it, so I'm inclined to backport as is on the basis of making things more consistent
[10:59:04] <gmcharlt> and discussion about the heading can be the subject of a new bug
[11:00:19] <kmlussier> Yes, I can see your point. At the time, I was thinking Activate was a better column heading, but today, "Active On" seems better. I could go with that as long as it's the same in both places.
[11:00:41] <gmcharlt> @coinflip
[11:00:43] <pinesol_green> gmcharlt: It reads like a Nigerian 419 scam, but I think it is a sincere question sent to the wrong list.
[11:00:59] <gmcharlt> @decide "Active On" or "Activate"
[11:00:59] <pinesol_green> gmcharlt: go with Active On
[11:01:33] <gmcharlt> there we have it! ;)
[11:01:45] <gmcharlt> I'll backport as is, then open a new bug
[11:06:39] <kmlussier> gmcharlt: Thanks. If you like, I can create a branch for the new bug.

Galen Charlton (gmc) on 2016-08-10
Changed in evergreen:
importance: Undecided → Low
Terran McCanna (tmccanna) wrote :

+1

Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) wrote :

Working branch available at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1611815-active-on-not-activate

I'm changing the targets to apply to 2.10 only since I am now working on more of a new feature-ish solution to be included in 2.11, as described in the below IRC discussion:

[11:11:10] <kmlussier> My memory is beginning to clear. I think the reason I didn't like "Active On" is because, for unsuspended holds, the user might think it should be listing the date the hold was placed. Maybe Activate Date is better, but it takes up more space.
[11:11:16] * kmlussier hates semantics
[11:12:30] <tsbere> kmlussier: "Restore On"?
[11:13:08] <gmcharlt> a possibility for a long-term improvement would be consolidating the "Active On", "Active", "Date Fulfilled", and "Status" column into a single status column
[11:14:58] <kmlussier> Yes, actually, I think that makes sense. Because you don't really care what the Activation date is unless it's suspended. Maybe I'll look at that before the 2.11 cutoff, but do the simpler branch for backport to 2.10
[11:23:26] <gmcharlt> kmlussier: +1

I'll open a new bug for that approach.

Changed in evergreen:
milestone: 2.11-beta → none
Kathy Lussier (klussier) wrote :

I force pushed an update to the above working branch. I had inadvertently changed the dropdown menu action item label instead of the column header in holds.tt2. Many thanks to csharp for pointing it out.

It should be ready for inclusion in 2.10 now. I'll add a pullrequest tag.

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

While working on bug 1614807, I realized we also need to make this label change in style.css.tt2 so that the label displays consistently on small screens too. I'm removing the pullrequest for now and will update the branch shortly.

tags: removed: pullrequest
tags: added: opac
removed: tpac
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers