Add to My List link should be removed from metarecord Grouped Search Results page

Bug #1599894 reported by Kathy Lussier on 2016-07-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.11
Medium
Unassigned
2.12
Medium
Unassigned

Bug Description

Evergreen version: all

When conducting a metarecord search, the "Add to My List" button displays on the Grouped Search Results page. If a user clicks it, the catalog will use the metarecord id to add a record to the list. However, since My List only works with individual bib records, the bib record that has an id that matches the metarecord id will be added to the list.

A screencast showing this behavior is available at https://drive.google.com/file/d/0B74gDMUDwDXqN04xRk1GZXJxSzg/view

The Add to My List link should be removed from the Grouped Search results page until such a time when lists are enhanced to support the addition of metarecords, if that time ever arrives.

Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) on 2017-09-01
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
milestone: none → 3.0-alpha
Kathy Lussier (klussier) wrote :

Thank you Cesar. Works for me!

I merged your branch to master and also backported it to 2.11 and 2.12.

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
status: Confirmed → Fix Committed
Blake GH (bmagic) wrote :

This might be simplified to [% IF !rec.mmr_id %]

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers