Authority right-click interface is incredibly slow when authority records contain a lot of 4xx fields

Bug #1586535 reported by Jane Sandberg
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Won't Fix

Bug Description

DLC's authority record for the country Turkey, which we are using, contains 228 See From headings in its MARC 451 fields. Unfortunately, this means that whenever we attempt to use the right-click authority interface on terms that are close to Turkey alphabetically, it takes 2-3 minutes for the interface to appear, since it has to load all 228 headings (and also shows Turkey several times in the interface, since many of the 228 headings are alphabetically close to Turkey).

It seems like this would perhaps be helped by limiting the See From references to those that are close alphabetically to the present heading and some logic that would avoid presenting the exact same heading several times in a row. What are your ideas for fixing this?

P.S. I'm using Evergreen 2.9.1.
P.P.S. The DLC's monster authority record for Turkey can be found here:

description: updated
Revision history for this message
Rogan Hamby (rogan-hamby) wrote :

I think improving the speed on the response to the rick clicking is a good wishlist item. I would be curious to hear from other catalogers about their experiences too.

Revision history for this message
Elaine Hardy (ehardy) wrote :

In general, speed is definitely an issue with the right click authority browse, as is where you land in the browse list. It isn't unusual that it takes a minute or longer to respond and then end up far from the actual heading.

I tried this particular heading and it locked up Evergreen after over 3 and a half minutes. I had to shut down the staff client using task manager....Logged back in and tried again. The af record never loaded. We are on 2.9.1 and I am on my laptop)

Revision history for this message
Jane Sandberg (sandbergja) wrote :

Note: this is much faster in the Web client, but still takes ~1 minute for this to load for us.

Revision history for this message
Jane Sandberg (sandbergja) wrote :

Actually, scratch that -- I was on a slow Internet connection. The Web client is fast fast fast for me, only taking about 2-3 seconds to load this interface. :-D

tags: added: fixedinwebby
Revision history for this message
Jane Sandberg (sandbergja) wrote :

Set to "Won't Fix", since it was really a XUL client problem.

Changed in evergreen:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers