The make_release script should always create a DB upgrade script.

Bug #1583608 reported by Jason Stephenson on 2016-05-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.10
Undecided
Unassigned
2.9
Undecided
Unassigned

Bug Description

Building the 2.9.5 tarball yesterday, I was surprised to discover that the make_release script does not create a DB upgrade script when there are no DB upgrades to apply. At a gross level, this makes perfect sense.

However, I think it will lead to confusion when people try to upgrade and there is no upgrade script to run. Also, there will be no entry in the DB upgrade log that the version was applied. A newly installed system will have a log entry of the currently installed Evergreen version.

I propose to modify make_release to output a minimal upgrade script that simply inserts the Evergreen version into config.upgrade_log when there are no actual database upgrades to apply.

Since this only affects maintainers building tarballs, I also suggest that this be backported to the currently supported releases, 2.9 and 2.10. If anyone disagrees, please elaborate your reasons in the comment section.

Jim Keenan (jkeenan) wrote :

I don't disagree. I think this is a fine idea.

Galen Charlton (gmc) wrote :

+1

+1

On Thu, May 19, 2016 at 10:08 AM, Galen Charlton <email address hidden> wrote:

> +1
>
> --
> You received this bug notification because you are subscribed to
> Evergreen.
> https://bugs.launchpad.net/bugs/1583608
>
> Title:
> The make_release script should always create a DB upgrade script.
>
> Status in Evergreen:
> New
>
> Bug description:
> Building the 2.9.5 tarball yesterday, I was surprised to discover that
> the make_release script does not create a DB upgrade script when there
> are no DB upgrades to apply. At a gross level, this makes perfect
> sense.
>
> However, I think it will lead to confusion when people try to upgrade
> and there is no upgrade script to run. Also, there will be no entry in
> the DB upgrade log that the version was applied. A newly installed
> system will have a log entry of the currently installed Evergreen
> version.
>
> I propose to modify make_release to output a minimal upgrade script
> that simply inserts the Evergreen version into config.upgrade_log when
> there are no actual database upgrades to apply.
>
> Since this only affects maintainers building tarballs, I also suggest
> that this be backported to the currently supported releases, 2.9 and
> 2.10. If anyone disagrees, please elaborate your reasons in the
> comment section.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1583608/+subscriptions
>

--
Chris Sharp
PINES System Administrator
Georgia Public Library Service
1800 Century Place, Suite 150
Atlanta, Georgia 30345
(404) 235-7147

Changed in evergreen:
milestone: none → 2.next
assignee: nobody → Jason Stephenson (jstephenson)
status: New → In Progress
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
status: In Progress → Confirmed
Jason Stephenson (jstephenson) wrote :

I have pushed a working branch based on master to working/user/dyrcona/lp1583608-make_release-always-db-upgrade.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1583608-make_release-always-db-upgrade

I have tested it with a practice 2.9.6 build. It produces an upgrade script that does the bare minimum of inserting the version into config.upgrade_log when there are no db upgrades.

I also made a custom, 2.8.8 to 2.9.6 upgrade tarball and that one had commands in the upgrade script, so it still works when there are db upgrades to do.

tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

Mike Rylander said it was OK to push this small change in IRC:

http://irc.evergreen-ils.org/evergreen/2016-08-24#i_263379

Since it is small and typically only affects those building source code tarballs for release, I think that is good enough to push it.

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: 2.next → 2.11-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers