MARC stream importer deletes wrong record on authority import

Bug #1580676 reported by Bill Erickson
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Medium
Unassigned

Bug Description

Evergreen 2.10.3, affects all versions

After successfully importing an authority record, marc_stream_importer.pl attempts to delete the queued vandelay authority record, consistent with bib record imports. However, the code only knows how to delete queued bib records. This results in a delete call on a queued bib record using the ID of the queued authority record. Hijinks ensue.

Patch en route.

Revision history for this message
Bill Erickson (berick) wrote :

Fix pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1580676-stream-auth-delete-repair

Considering options for how best to test this. It's more complicated that most Perl changes, since it requires running the importer service and importing records. May have to rely on humans.

To test:

1. Run marc_stream_importer.pl with command line arguments sufficient for importing authority records.
2. Import an authority record.
3. Confirm the vandelay copy of the authority record (vandelay.queued_authority_record) is deleted after the record is successfully imported.

The logs will show a call to open-ils.pcrud.delete.vqar, which would not have appeared before applying this patch, since it was always calling the .vqbr version of the API.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.10.4
Revision history for this message
Galen Charlton (gmc) wrote :

Removed 2.9 target: marc_stream_importer.pl didn't support authority record import prior to 2.10.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
no longer affects: evergreen/2.9
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_10, along with a follow-up that corrects the error message if the record could not be cleaned up. Thanks, Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers