webstaff: remove statusbar, move Hatch connection indicator to hamburger menu

Bug #1564508 reported by Galen Charlton on 2016-03-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

The browser client has a status bar that is currently hidden. It supports the following features:

- notification system
- websockets connection status indicator
- Hatch status indicator

The notification system has been supplanted by toasts from ngToast. However, since having an indication of whether Hatch is connected or not would be handy, I suggest:

- removing the status bar
- adding a Hatch connection status indicator to the hamburger menu
- optionally adding a websockets connection status indicator to the hamburger menu

Bill Erickson (berick) wrote :

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1564508-hatch-status-hamburger

From the commit:

* Move the Hatch connectivity status indicator into the upper-right hamburger menu.

* Removes the long-hidden hatch/websockets statusbar.

* Since the Hamburger forces a re-digest of the interface when opened, the code no longer attempts to force the page to re-$apply() when the Hatch connection opens or closes. It's no longer necessary (and was buggy).

* The WebSockets connectivity status is not added to the hamburger. The websockets connection will go up and down regularly as connections expire and reset. Having the indicator flash could lead to unnecessary panic (IMO). Plus, if websockets are down, staff can't log in anyway.

tags: added: pullrequest
tags: added: webstaffclient
Changed in evergreen:
status: New → Confirmed
Bill Erickson (berick) wrote :

Rebased working branch to current master.

Bill Erickson (berick) on 2017-05-15
Changed in evergreen:
milestone: 3.next → 3.0-alpha
Galen Charlton (gmc) wrote :

Tested and signed-off; I've also written a follow-up that makes the Hatch status menu item display as disabled. Signoff branch is user/gmcharlt/lp1564508_signoff.

tags: added: signedoff
Bill Erickson (berick) on 2017-05-19
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Good thinking, Galen. Signed off the new commit. Merged to master. Thanks!

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers