Importing MARC records can fail in database upgraded to 2.10.0

Bug #1560174 reported by Galen Charlton on 2016-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Critical
Unassigned
2.10
Critical
Unassigned

Bug Description

Due to an error in the 0962.schema.vandelay-parts-import.sql script, using Vandelay to import bib records can fail with the following Pg error:

ERROR: column "attr" does not exist
...
CONTEXT: PL/pgSQL function vandelay.ingest_items(bigint,bigint)

This occurs only if the database was upgraded to 2.10.0; a new Evergreen database will have the correct version of the vandelay.ingest_items() stored function.

Evergreen 2.10.0

Galen Charlton (gmc) on 2016-03-21
Changed in evergreen:
milestone: none → 2.10.1
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1560174_fix_vandelay_oops branch in the working/Evergreen repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1560174_fix_vandelay_oops

tags: added: pullrequest
Dan Wells (dbw2) on 2016-03-21
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

So sorry to be the root cause of this. Fix looks good, pushed to master and rel_2_10. Thanks, Galen!

Changed in evergreen:
assignee: Dan Wells (dbw2) → nobody
milestone: 2.10.1 → none
status: New → Fix Committed
Galen Charlton (gmc) on 2016-03-23
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers