Web staff Client - MARC Edit Character Map missing

Bug #1555766 reported by Christine Burns on 2016-03-10
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

In the current staff client -> in MARC Edit interface -> Ctrl + S opens a character map for entering diacritics

This character map is missing from the web client. Clicking Ctrl+S opens save as window

Can we add the character map to the web client with a different keyboard shortcut combination?

Galen Charlton (gmc) wrote :

Noting for future reference, as this feature isn't presently documented in the community documentation and isn't referenced in the XUL MARC editor's help -- this is the feature described in http://comments.gmane.org/gmane.education.libraries.open-ils.devel/5655

Changed in evergreen:
status: New → Confirmed
Andrea Neiman (aneiman) on 2017-07-19
tags: added: cataloging
Andrea Neiman (aneiman) on 2017-09-13
Changed in evergreen:
importance: Undecided → Medium
milestone: none → 3.0-beta2
Changed in evergreen:
milestone: 3.0-beta2 → 3.0-rc
Galen Charlton (gmc) on 2017-09-27
Changed in evergreen:
milestone: 3.0-rc → 3.0.1
Changed in evergreen:
milestone: 3.0.1 → 3.0.2
Changed in evergreen:
milestone: 3.0.2 → 3.0.3
Changed in evergreen:
milestone: 3.0.3 → 3.0.4
Changed in evergreen:
milestone: 3.0.4 → 3.0.5
Changed in evergreen:
milestone: 3.0.5 → 3.0.6
Changed in evergreen:
milestone: 3.0.6 → 3.0.7
Changed in evergreen:
milestone: 3.0.7 → 3.0.8
Changed in evergreen:
milestone: 3.0.8 → 3.1.3
Changed in evergreen:
milestone: 3.1.3 → 3.1.4
Jason Etheridge (phasefx) wrote :

I'd like to argue for using OS native tools for this.

For example, depending on the flavor of Windows, Start -> Run or Start -> Search Box, -> charmap (aka Character Mapper)

It's more feature rich than what is in the XUL now, but does have to work through the clipboard.

For Mac OS X, System Preferences -> Keyboard -> Show Keyboard & Character Viewer in menu bar; then use Show Character Viewer from said menu.

Changed in evergreen:
milestone: 3.1.4 → 3.1.5
Chris Sharp (chrissharp123) wrote :

Marking this Won't Fix, since OS native tools can replace this functionality. If others disagree, please speak up!

Changed in evergreen:
status: Confirmed → Won't Fix
milestone: 3.1.5 → none
Anna Goben (agoben) wrote :

I'm popping in to disagree. Having the map embedded in the editor saves many steps/clicks and is simply much more efficient in the long run. Leaving the client to go use another piece of software several times per record is not user friendly for our catalogers. Comparing the workflows, it seems to be obvious:

Staff client:
1) Press CRTL+S
2) Click on desired character which automatically places the character where the cursor is.

Proposed solution above:
1) Leave Evergreen.
2) Open other piece of software (character map).
3) Search for character.
4) Copy to clipboard.
5) Return to Evergreen.
6) Place cursor in record.
7) Paste.

Please reopen this bug!

Kathy Lussier (klussier) on 2018-10-24
Changed in evergreen:
status: Won't Fix → Confirmed
importance: Medium → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments