Add Evergreen support for Ubuntu 16.04 Xenial Xerus

Bug #1551084 reported by Ben Shum on 2016-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Evergreen master

Testing with Ubuntu 16.04 Xenial Xerus with their beta1 build.

Starting this working bug to track progress and notes for getting support in place for Ubuntu 16.04, which has its final release due out around April 21, 2016.

Ben Shum (bshum) on 2016-02-29
Changed in evergreen:
milestone: none → 2.next
status: New → In Progress
assignee: nobody → Ben Shum (bshum)
importance: Undecided → Wishlist
Ben Shum (bshum) wrote :
Ben Shum (bshum) on 2016-02-29
summary: - Add support for Ubuntu 16.04 Xenial Xerus
+ Add Evergreen support for Ubuntu 16.04 Xenial Xerus
Ben Shum (bshum) on 2016-02-29
Changed in evergreen:
assignee: Ben Shum (bshum) → nobody
status: In Progress → Triaged
Jason Stephenson (jstephenson) wrote :

Testing this in the airport before leaving for the conference.

I am getting this when starting Apache on Xenial:

Invalid command 'PerlRequire', perhaps misspelled or defined by a module not included in the server configuration.

Looks like mod_perl failed. I'll have to check it out later.

I also had to fix the ubuntu-xenial-developer install target. That will show up in a forthcoming branch. I'll probably push that when I figure out the above.

Ben Shum (bshum) wrote :

Oops, I see the typo in my branch. I tacked on a minor correction to the collab but it can probably get squashed, etc. later on.

Checking out the rest of the install next. Using the xenial server daily build from 2016-04-17.

Ben Shum (bshum) wrote :

I can confirm Jason's finding for perl module not being loaded on Apache with latest Xenial build. It didn't do this to me before during beta1 testing for Xenial, so it must be a more recent change.

Doing "a2enmod perl" as the root or sudo user allowed me to proceed with apache startup as normal. I'm wondering if maybe we should add it to the end of the opensrf Makefile.install as another forced apache module start, for just in case. We do this already in opensrf with auto disabling mpm_event and turning on mpm_prefork.

Refer to bug 1551090 for OpenSRF changes for 16.04.

Ben Shum (bshum) wrote :

Rebased to recent master and here: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/bshum/ubuntu-1604-final

Will start a new bug later for dropping 12.04 support once this is merged.

Jason Stephenson (jstephenson) wrote :

Tested and pushed to master for great justice!

Thanks, Ben!

Changed in evergreen:
status: Triaged → Fix Committed
Changed in evergreen:
milestone: 2.next → 2.11-alpha
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers