EDI Default Cancel Reason for Baker & Taylor not included: Code 85

Bug #1550495 reported by Josh Stompro on 2016-02-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.8
Medium
Unassigned
2.9
Medium
Unassigned

Bug Description

EG 2.8.4

I just recently figured out that the reason none of our EDI Cancellations were registering in our system is because the code that Baker & Taylor was sending back to us wasn't entered in the acq.cancel_reason.

Baker & Taylor uses code 85 when they cancel a line item immediately for our implementation.

Since it is a bit obscure to add these codes and it cannot be done from the staff client I wonder if it would be appropriate to add this one to the base install, so if anyone else starts using EDI with B&T this code wouldn't need to be added manually. And add it to existing installs if it hasn't already been added.

And by obscure I just mean that the row ID for the entry needs to be 1200+<code> to be used by the EDI subsystem. I don't see any mention of that in the EDI setup docs in the official 2.8 docs.

Can someone else that uses EDI with B&T let me know if you also use cancel code 85 please.

Thanks
Josh

Christine Morgan (cmorgan-z) wrote :

EG 2.9.1

Hi Josh,

Several of our libraries order from B&T using EDI. In checking some of the ORDRSP files I can see that code 85 is being use for our implementation as well. I do not see code 85 (or row id 1285) in acq.cancel_reason either. I am no EDI expert but I would think that adding this to the base install would be appropriate.

Hope this helps,
Christine

Thanks Christine, would you please see if you have the following messages in your logs letting you know that the system looked for cancel reason 85 but couldn't find it.

"EDI: Unhandled quantity qty_code '85' for li"

In our setup they are in the osrfwarn logs.

fgrep "EDI: Unhandled quantity qty_code '85' for li" osrfwarn.*.log

Josh

Christine Morgan (cmorgan-z) wrote :

Hi Josh,

Yes. We find "EDI: Unhandled quantity qty_code '85' for li" in our osrfsys.*.log

Christine

Changed in evergreen:
assignee: nobody → Josh Stompro (u-launchpad-stompro-org)
tags: added: acq
tags: added: pullrequest
Changed in evergreen:
assignee: Josh Stompro (u-launchpad-stompro-org) → nobody
Galen Charlton (gmc) wrote :

Looks like commit e5efc965ba had gone too far.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 2.10-rc
Galen Charlton (gmc) wrote :

EDItEUR also recognized 85 as a valid quantity quantifier, so I'm pushing this all the way back to rel_2_8. Thanks, Josh!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers