webclient: Second checkin of precat does not create alert to send to cataloging

Bug #1537228 reported by Kathy Lussier on 2016-01-22
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.0
Undecided
Unassigned

Bug Description

In the web client, you only receive the alert to send a precat to cataloging the first time you check in a precat. On subsequent checkins, the popup alert does not appear.

My expectation is that the popup alert would appear each time the precat is scanned at checkin.

Andrea Neiman (aneiman) wrote :

confirmed in 2.11 and 2.12 -- noting that XUL client does alert with popup on subsequent precat checkins.

Changed in evergreen:
status: New → Confirmed
Jane Sandberg (sandbej) on 2018-05-22
tags: added: cataloging
Jane Sandberg (sandbej) on 2018-05-22
Changed in evergreen:
importance: Undecided → Medium
Jane Sandberg (sandbej) wrote :

Here's a branch that makes the Web client behave like the XUL client: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1537228_display_precat_alert_on_every_checkin
The branch is called user/sandbergja/lp1537228_display_precat_alert_on_every_checkin

However, I would really appreciate more experienced eyes to take a look at this, since I can't figure out *why* the XUL client was acting the way it did. :-/

I have to say that we *much* prefer the behavior of showing the alert every time the precat is checked in. We want to make sure things get to our cataloger, even if we miss the alert the first time. :-)

tags: added: pullrequest
Dawn Dale (ddale) on 2018-05-22
Changed in evergreen:
assignee: nobody → Dawn Dale (ddale)
Dawn Dale (ddale) wrote :

This appears to be working as expected. Checking in a precat multiple times produces a receipt to route to cataloging.

Dawn Dale (ddale) wrote :

I have tested this code and consent to signing off on it with my name,
Dawn Dale and my email address, <email address hidden>

Changed in evergreen:
assignee: Dawn Dale (ddale) → nobody
tags: added: signedoff
Bill Erickson (berick) on 2018-05-23
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: Confirmed → In Progress
Bill Erickson (berick) wrote :

Thanks for the patch and comments, Jane! Regarding your question about why the XUL client was acting that way, I've pushed an alternate branch that makes the browser client act just like the XUL client. Specifically, it teaches the client to show the alert when a precat is checked in, even when the server says "no change occurred". I prefer this approach because it does not change the API (and for general consistency).

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1537228-precat-subsequent-checkins-alert

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
status: In Progress → Confirmed
milestone: none → 3.1.2
tags: removed: signedoff
Jane Sandberg (sandbej) wrote :

Thanks for lending your expert eye and providing a new patch, Bill!

Jane Sandberg (sandbej) wrote :

I had the opportunity to test Bill's branch, and it works great.

I have tested this code and consent to signing off on it with my name, Jane Sandberg, and my email address, <email address hidden>.

Changed in evergreen:
milestone: 3.1.2 → 3.1.3
Andrea Neiman (aneiman) on 2018-05-29
tags: added: signedoff
Changed in evergreen:
milestone: 3.1.3 → 3.1.4
Chris Sharp (chrissharp123) wrote :

Pushed to master, rel_3_0, and rel_3_1.

Thanks to all!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers