checkin with the clear hold shelf modifier can time out

Bug #1526858 reported by Galen Charlton
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.10
Medium
Unassigned
2.9
Medium
Unassigned

Bug Description

When checking in an item using Clear Holds Shelf Checkin Modifier, the call can fail due to a query to identify holds to cancel timing out:

method=open-ils.circ.checkin
params=["XXX",{"barcode":"123456","clear_expired":1}]
THROWN:
{"payload":[],"debug":"osrfMethodException : *** Call to [open-ils.circ.checkin] failed for session [FOO], thread trace [1]:\nException: OpenSRF::DomainObject::oilsMethodException 2015-06-20T14:42:58 OpenSRF::Application /usr/local/share/perl/5.10.1/OpenSRF/Application.pm:233 <500> No active transaction to roll back\n\n","status":500}
STATUS:

Evergreen master

Revision history for this message
Galen Charlton (gmc) wrote :

A patch for this can be found at the tip of the user/gmcharlt/lp1526858_query_alhr_faster branch in the working/Evergreen repository.

Revision history for this message
Kathy Lussier (klussier) wrote :

Galen, is this branch ready for a pullrequest tag?

Galen Charlton (gmc)
tags: added: pullrequest
Revision history for this message
Jeanette Lundgren (jlundgren) wrote :

C/W MARS has been using this in production since 2.8.4 and also applied to 2.9.5.

I am signing off on this bug: Jeanette Lundgren (C/W MARS).

Thank you Galen for this patch!

Changed in evergreen:
status: New → Confirmed
tags: added: signedoff
Revision history for this message
Michele Morgan (mmorgan) wrote :

Just ran into this bug in our 2.9.1 system. Would be great to get this in.

Adding a link to the branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1526858_query_alhr_faster

Kathy Lussier (klussier)
Changed in evergreen:
milestone: none → 2.next
Revision history for this message
Kathy Lussier (klussier) wrote :

Thank you Galen and Jeanette. Signed off and merged to master, 2.10, and 2.9.

Changed in evergreen:
status: Confirmed → Fix Committed
importance: Undecided → Medium
Changed in evergreen:
milestone: 2.next → 2.11-alpha
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers