web client: Insufficient permissions causes actions to fail without any feedback to the user

Bug #1526185 reported by Kathy Lussier
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

In the web client, if staff does not have permission to perform an action, the action will fail without any feedback to the user. I tested the following actions with an account that did not have sufficient permissions:

COPY_ALERT_MESSAGE.override
COPY_STATUS_LOST.override
PATRON_EXCEEDS_FINES.override
UPDATE_HOLD

In every case, the user never received a message saying why the action failed and did not receive a login box asking for credentials of an account that could perform the action. In several cases, it wasn't even clear that the action had failed

Kyle Huckins (khuckins)
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Revision history for this message
Kyle Huckins (khuckins) wrote :

Bill Erickson and I have a collab branch here that resolves this:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/khuckins/lp1526185-permission-credentials-prompt

Evergreen should now notice whenever an action fails due to permission failure, and the recently implemented operator change dialog will be brought up(without the login type field), along with a message as to what permission failed, and a human-readable message summarising the issue. Input of authorized credentials will log you in as the authorized user, re-attempt the action, and then return you to your user.

tags: added: pullrequest
Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
Bill Erickson (berick)
Changed in evergreen:
milestone: none → 2.12-beta
status: New → Confirmed
Changed in evergreen:
milestone: 2.12-beta → 2.12-rc
Revision history for this message
Kathy Lussier (klussier) wrote :

I'm getting merge conflicts on this one. Could somebody rebase the branch against current master?

Revision history for this message
Bill Erickson (berick) wrote :

Rebasing now...

Revision history for this message
Bill Erickson (berick) wrote :
Revision history for this message
Kathy Lussier (klussier) wrote :

Thank you Kyle and Bill! Merged to master for inclusion in 2.12.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers