Web client: Checkout auto renew age OU setting is not honored

Bug #1526163 reported by Kathy Lussier on 2015-12-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Tested on a system with a checkout auto renew setting of 6 days. In the web client, when I attempted to check out an item to a patron who already had the item checked out for more than 6 days, I received a prompt asking me if I wanted to renew the item or cancel the transaction. The expected behavior is for the client to automatically renew the item without a prompt.

Billy Horn (bhorn) on 2016-11-14
Changed in evergreen:
assignee: nobody → Billy Horn (bhorn)
Billy Horn (bhorn) wrote :

I have pushed a commit here http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bhorn/LP1526163-checkout-auto-renew-not-honored

It adds a check during checkout for the auto renew policy and also adds a check to make sure the items out count doesn't increase if the current transaction is a renew.

tags: added: pullrequest
Changed in evergreen:
assignee: Billy Horn (bhorn) → nobody
Bill Erickson (berick) on 2017-02-03
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: New → Confirmed
Bill Erickson (berick) wrote :

Thanks, Billy.

I have pushed a new branch here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1526163-webstaff-auto-renew

It includes a sign-off for Billy's code, plus a secondary commit:

==
Initiate the auto-renewal earlier in the checkout process, specifically before checkout response data is unnecessarily fleshed. Add an explicit auto_renew toggle to the checkout response blob to more clearly indicate why checkout counts are not modified.

Additional code comments and logging.
==

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
milestone: none → 2.12-beta
Changed in evergreen:
milestone: 2.12-beta → 2.12-rc
Kathy Lussier (klussier) wrote :

It works for me. Pushed to master for inclusion in 2.12. Thank you Billy and Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers