Purchase Orders with spaces in the name cause problems with EDI processing

Bug #1519465 reported by Jason Stephenson on 2015-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.8
Medium
Unassigned
2.9
Medium
Unassigned

Bug Description

Evergreen: 2.7.2ish
PostgreSQL: 9.3 (n/a)
OpenSRF: 2.4ish (n/a)

When staff enter a purchase order with a space in the name, this causes a problem with picking line item ids out of the invoice and other messages returned by the vendor.

Bill Erickson and Kathy Lussier traced this to a regex used to parse these ID numbers. It currently includes a check for non-space characters.

Since staff are not prevented from entering spaces in PO names, and since vendors do not seem to have a problem with it, a proposed solution is to alter the regular expression.

See the forthcoming branch for that solution.

Jason Stephenson (jstephenson) wrote :

Fix pushed to user/dyrcona/lp1519465-po-spaces in the working repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1519465-po-spaces

tags: added: pullrequest
Kathy Lussier (klussier) on 2015-12-09
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 2.next
Ben Shum (bshum) wrote :

Pushed to master, backported to rel_2_9 and rel_2_8.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 2.next → 2.10-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers