Claimed never checked out count not increased when applied to LOST circulation

Bug #1496556 reported by Blake GH on 2015-09-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.10
Undecided
Unassigned
2.9
Undecided
Unassigned

Bug Description

OpenSRF 2.24
EG 2.8.2
PG 9.2

Using the "Claim Never Checked Out" action on a circulation that is Lost (with bills) does not result in actor.usr.claims_never_checked_out_count being increased.

Blake GH (bmagic) wrote :

The library setting "Claim Never Checked Out: Mark copy as missing" is set to True which results in an override for "COPY_STATUS_LOST"

Michele Morgan (mmorgan) wrote :

Confirmed. Additionally, action.circulation.stop_fines remains LOST for the transaction, instead of changing to CLAIMSNEVERCHECKEDOUT.

Changed in evergreen:
status: New → Confirmed
Blake GH (bmagic) wrote :
Changed in evergreen:
assignee: nobody → Blake GH (blake-j)
tags: added: pullrequest
Changed in evergreen:
assignee: Blake GH (blake-j) → nobody
Mike Rylander (mrylander) wrote :

Applied to master, thanks Blake!

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 2.11-beta
Kathy Lussier (klussier) wrote :

I came across this bug when checking for missing release notes. It looks like a bug fix to me, and I think it should be considered for backporting for 2.9 and 2.10. I'm going to apply targets so that the release maintainers can make the final decision on backporting.

Jason Stephenson (jstephenson) wrote :

The change cherry-picks cleanly into rel_2_9 and looks simple and obvious enough. I recommend a backport, but I won't backport to 2.9 unless Galen also decides to backport to 2.10.

Galen Charlton (gmc) wrote :

I've backported this to rel_2_10 and rel_2_9.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers