OPAC Column sorting - leading articles are not rendered in smaller font

Bug #1494750 reported by Mary Jinglewski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Low
Unassigned
2.10
Fix Released
Low
Unassigned
2.11
Fix Released
Low
Unassigned

Bug Description

In Evergreen 2.9 - rc, the release notes (2.6.2. Column sorting in circulation screens) describe a new sorting feature with in the My Account section for Items Checked Out, Check Out History, and Holds screens: "Title sorting is done with the so-called ‘filing’ characters (leading “the”, “a”, “an”, and other langugage equivalents) removed. The leading articles are rendered in a smaller font, so as to keep the main entry prominent."

There is no problem with the title sorting as described above. However, the leading articles - assumed to be the same "the," "a," "and," etc. at the beginning of a title - are not rendered in a smaller font. Please see the attached screenshot of Items Checked Out with items sorted by title that was taken within the EG Community server.

Revision history for this message
Mary Jinglewski (maryj-deactivatedaccount) wrote :
Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

I think that this is a CSS error. It looks like there is an extra closing curly bracket before the .sort_ that disables that entry. Remove it and the non filing characters are de-emphasized as intended.

It shows up as an error when I run it through csslint.net. I wonder if running all the generated css files through a css checker would be a good test to add?

My two character (there was a trailing space) change branch is at

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1494750_title_sort_deemphasize_css

Josh

tags: added: pullrequest
Revision history for this message
Jeanette Lundgren (jlundgren) wrote :

I plan to test this on bug squashing day.

Changed in evergreen:
assignee: nobody → Jeanette Lundgren (jlundgren)
Revision history for this message
Jeanette Lundgren (jlundgren) wrote :

I have tested this in Current Items Checked Out, Check Out History, and Items on Hold. Leading articles are displayed in a smaller font. Specifically I tested, A, The, Le, La, Les.

I have tested this code and consent to signing off on it with my name, Jeanette Lundgren and my email <email address hidden>.

tags: added: signedoff
Changed in evergreen:
assignee: Jeanette Lundgren (jlundgren) → nobody
Revision history for this message
Kathy Lussier (klussier) wrote :

Thank you Josh and Jeanette! Signed off and pushed to master, 2.11 and 2.10.

Changed in evergreen:
milestone: none → 2.next
status: New → Fix Committed
importance: Undecided → Low
Changed in evergreen:
milestone: 2.next → 2.12-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.