Staff client refund option generates an error

Bug #1494427 reported by Kathy Lussier
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen version: 2.9RC

Tested on the MassLNC community demo server. Retrieve a patron record with a negative balance in the patron's bills interface, right-click on the transaction and select the "Refund" option. The client generates the following error:

*** Failed to get string staff.patron.bills.handle_refund.confirm_message in bundle: /xul/2015_09mlnc4_09_095756/server/locale/en-US/patron.properties
undefined

Revision history for this message
Kathy Lussier (klussier) wrote :

This working branch restores the refund function back to its behavior in 2.8:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1494427-fix-refund-error

However, I also want to make note that, although I've added the staff.patron.bills.handle_refund.confirm_message back to the patron.properties file, as far as I can tell, this string never gets displayed. It didn't display in 2.8 either.

I was tempted to just remove the string from the handle_refund function in bill2.js, but I was worried that the string was being displayed somewhere and I was just missing it. I'm happy to do a new branch to remove the string from the function if it's a better approach.

Test case:

Find a negative balance transaction and, from the patron's bills
record, select the transaction and select the option to Refund. Pre-patch, this
action will generate an error message. Post-patch, this action should generate
a prompt asking the user to confirm the action.

tags: added: pullrequest
Kathy Lussier (klussier)
Changed in evergreen:
milestone: none → 2.9.0
Revision history for this message
Kathy Lussier (klussier) wrote :

Alternate approach that removes the unused string along with a similar unused string in the adjust-to-zero function is available at:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1494427-fix-refund-error

Revision history for this message
Jason Etheridge (phasefx) wrote :
Revision history for this message
Kathy Lussier (klussier) wrote :

Thanks for correcting my link Jason!

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Jason Stephenson (jstephenson) wrote :

Works for me! Pushed to master for 2.9.0. Thanks, Kathy!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers