WARNING for Penalty.pm during make install

Bug #1486800 reported by Ben Shum on 2015-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen master / 2.9

With the changes from bug 1312308, open-ils.penalty service was removed (see http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=432a106facf4ee93e544408d70524f06d55ff56e in master).

When performing a make install afterwards, we see this warning in the console:

WARNING: the following files are missing in your kit:
 lib/OpenILS/Application/Penalty.pm
Please inform the author.

Looking around, I can see that we may need to remove the entry for lib/OpenILS/Application/Penalty.pm from OpenILS/lib/perlmods/MANIFEST.

Confirmed in IRC on http://irc.evergreen-ils.org/evergreen/2015-08-19

Working branch forthcoming once I have an LP number.

Ben Shum (bshum) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.9-rc
summary: - WARNING for Penalty.pm in make install
+ WARNING for Penalty.pm during make install
Galen Charlton (gmc) wrote :

Pushed to master. Thanks, Ben!

A couple notes:

* looks like rel_2_9 has been branched yet; I'm assuming that will happen with the RC or the .0 release
* the MANIFEST lacks a number of new files that have been created over the years. I don't think that makes any practical difference, but it would if the OpenILS Perl modules ever become a separately-installable CPAN module or Debian package.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers