Copies in concerto data should have prices

Bug #1486592 reported by Kathy Lussier on 2015-08-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Copies in the concerto data do not have any prices set. The absence of price data makes it difficult to test any code or workflows related to setting transactions to lost or long overdue.

Michele Morgan (mmorgan) wrote :

Including prices in concerto copy records would certainly facilitate testing billing functionality, for both developers and new Evergreen users.

Changed in evergreen:
status: New → Confirmed
Changed in evergreen:
assignee: nobody → Chris Sharp (chrissharp123)
Michele Morgan (mmorgan) on 2015-12-16
tags: added: pullrequest
tags: added: needstest
Ben Shum (bshum) wrote :

Targeting this towards 2.next for now (so that it's not lost in the wild) till we're sure this is meant for 2.10 review and inclusion.

Changed in evergreen:
milestone: none → 2.next
tags: removed: needstest
Changed in evergreen:
milestone: 2.next → 2.10-beta
Ben Shum (bshum) wrote :

Works for the most part, however I uncovered about five copies that were created in the sample data that did not get a price included with them. I tracked those back to some individual entries in assets_concerto.sql.

Pushed a new working branch with my signoff for csharp's work along with an additional commit that includes changes to add random price for those additional copies.

Branch: user/bshum/add-price-to-concerto-data

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/add-price-to-concerto-data

Changed in evergreen:
assignee: Chris Sharp (chrissharp123) → nobody
Thomas Berezansky (tsbere) wrote :

To better emulate real-world data shouldn't we leave a few copies without prices?

Galen Charlton (gmc) wrote :

I've pushed Chris' patch as signed off by Ben to master -- thanks, Chris! I agree with Thomas that it makes sense to leave at least a few copies without prices, so I've not pushed Ben's follow-up.

Since a one-liner suffices to describe this for the sake of the release notes, I've tagged this with "rm-to-write-notes" as a reminder to myself to include this in a miscellaneous/minor section of the release notes when I cut 2.10.

Changed in evergreen:
status: Confirmed → Fix Committed
tags: added: rm-to-write-notes
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers