Add acquisitions data to the Concerto dataset

Bug #1486294 reported by Kathy Lussier on 2015-08-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

It would be very nice to have some acquisitions data in the Concerto dataset so that testers don't need to set up fund sources, funds, providers, etc. when testing acq enhancements and bug fixes. I'm opening this bug to track what would be needed.

* A handful of funds and fund sources owned by some of the org units in the sample data. It might be a good idea for branches to own some funds and systems to own others. We have libraries that do it both ways, and it would be good to ensure both structures are supported. Money should already be allocated to the fund sources and funds.

* The same OUs with funds should also have some providers. Including a MARC holdings tag and subfield information in each of the provider records would make it easier to test code related to MARC Order Record uploads.

* We should have some POs in an on-order state with a mix of lineitems that are on-order, delayed, canceled, and received. It probably wouldn't be a bad idea to have some POs in a received state too.

* We should also have some invoices, perhaps with lineitems linked to those received lineitems in the POs.

Any other ideas for sample data that we should include?

Bill Erickson (berick) on 2015-11-04
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
status: New → In Progress
Bill Erickson (berick) wrote :

Getting started here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1486294-acq-sample-data

Includes:

    * funding sources
    * funds
    * funding source credits
    * fund allocations
    * providers

Note that most providers represent real vendors with their real SAN's, since that will provide more accurate tests (e.g. processing EDI templates). Note that no EDI connection information is included.

Comments on the content appreciated. If the data as-is looks like a good start, I'd be in favor of merging it sooner than later. We can always continue from there.

Changed in evergreen:
status: In Progress → Confirmed
assignee: Bill Erickson (berick) → nobody

Looks good to me.

On Wed, Nov 4, 2015 at 5:10 PM, Bill Erickson <email address hidden> wrote:

> Getting started here:
>
> http://git.evergreen-
>
> ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1486294
> -acq-sample-data
>
> Includes:
>
> * funding sources
> * funds
> * funding source credits
> * fund allocations
> * providers
>
> Note that most providers represent real vendors with their real SAN's,
> since that will provide more accurate tests (e.g. processing EDI
> templates). Note that no EDI connection information is included.
>
> Comments on the content appreciated. If the data as-is looks like a
> good start, I'd be in favor of merging it sooner than later. We can
> always continue from there.
>
> ** Changed in: evergreen
> Status: In Progress => Confirmed
>
> ** Changed in: evergreen
> Assignee: Bill Erickson (berick) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to
> Evergreen.
> Matching subscriptions: evergreenbugs
> https://bugs.launchpad.net/bugs/1486294
>
> Title:
> Add acquisitions data to the Concerto dataset
>
> Status in Evergreen:
> Confirmed
>
> Bug description:
> It would be very nice to have some acquisitions data in the Concerto
> dataset so that testers don't need to set up fund sources, funds,
> providers, etc. when testing acq enhancements and bug fixes. I'm
> opening this bug to track what would be needed.
>
> * A handful of funds and fund sources owned by some of the org units
> in the sample data. It might be a good idea for branches to own some
> funds and systems to own others. We have libraries that do it both
> ways, and it would be good to ensure both structures are supported.
> Money should already be allocated to the fund sources and funds.
>
> * The same OUs with funds should also have some providers. Including a
> MARC holdings tag and subfield information in each of the provider
> records would make it easier to test code related to MARC Order Record
> uploads.
>
> * We should have some POs in an on-order state with a mix of lineitems
> that are on-order, delayed, canceled, and received. It probably
> wouldn't be a bad idea to have some POs in a received state too.
>
> * We should also have some invoices, perhaps with lineitems linked to
> those received lineitems in the POs.
>
> Any other ideas for sample data that we should include?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1486294/+subscriptions
>

Bill Erickson (berick) wrote :

Force-pushed to same branch, now with PO's, lineitems, lineitem details, and fund debits.

That's everything from Kathy's list, minus received PO's and invoices.

Bill Erickson (berick) wrote :

Note on above, the code as-is is merge-able, assuming it looks OK. I would +1 to merging it as is. This gets us a lot and I may not get to the rest any time soon. Adding pullrequest for exposure. If merged, leave the ticket open so we can pick up the remaining bits.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.next
Kathy Lussier (klussier) on 2015-11-05
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Bill Erickson (berick) wrote :

Pushed hold subfield maps for all providers.

Kathy Lussier (klussier) wrote :

Thank you Bill! The new sample data is going to save a lot of time for us when we test acquisitions. I signed-off on your commits and added a commit that adds a sample order record file to the datasets that can be used to test uploads against the sample data.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1486294-acq-sample-data

Bill Erickson (berick) wrote :

Signed off on final commit and pushed to master. Thanks, Kathy!

Going to leave this open to address the following:

* received PO's
* invoices

tags: added: acq
Ben Shum (bshum) wrote :

Part of this was merged already, if 2.10-beta is cut, should change status to fix committed, etc. and open a new bug to track progress for additional areas that berick mentioned.

Changed in evergreen:
milestone: 2.next → 2.10-beta
Galen Charlton (gmc) wrote :

As it is a little awkward to have partially completed bugs hanging around in LP, I've opened a new one for adding received POs and invoices: bug 1545185.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers