Use client TZ in the database when supplied to the server

Bug #1485374 reported by Mike Rylander on 2015-08-16
32
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Building upon https://bugs.launchpad.net/opensrf/+bug/1485371 where we teach OpenSRF to pass the client's timezone to the server, we can tell the database what timezone to use when interpreting any time stamps. Code coming soon...

Kathy Lussier (klussier) on 2015-08-18
tags: added: needsreleasenote
Mike Rylander (mrylander) wrote :

I've added two commits to this branch which disable the client-timezone use when in My Account, as due date should be presented in the server's time zone.

Mike Rylander (mrylander) wrote :

And, finally, a third commit that causes the server timezone to be used in perl methods that will ultimately display circulation due dates.

Mike Rylander (mrylander) wrote :

After much testing and thought, and an important bug fix from Galen, we've come to the realization that the correct scope of this is just the actual use of client timezones. To that end, some commits have been removed, and we'll follow up with bugs for future work that will further enhance the timezone support. Branch update with release notes and pullrequest coming soon!

Mike Rylander (mrylander) wrote :
tags: removed: needsreleasenote
Jason Stephenson (jstephenson) wrote :

The branch modifies code in Open-ILS/src/c-apps/oils_auth.c that has been deleted or moved in master. I resolved it during testing by simply deleting the conflicting code. I'm not sure if that is the proper solution. It didn't seem to break anything, but I didn't really pound on it or check for accuracy of timestamps in logs, etc.

Therefore, I think this branch needs a rebase.

Mike Rylander (mrylander) wrote :

OK! I've rebased here, and added some missing context-aware calls for fetching users and recording activity:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/miker/lp1485374-always-use-client-tz-rebase

Jason Stephenson (jstephenson) wrote :

Thanks, Mike!

I finally got around too looking at it and all seems well, except for a compiler error that was easy enough to fix.

I've pushed a sign off branch to collab/dyrcona/lp1485374-always-use-client-tz-signoff

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1485374-always-use-client-tz-signoff

I'm not sure that this should go into master right now because of the 2.11 freeze, but I'll leave that up to you (Mike) and Dan Wells to work out.

tags: added: signedoff
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.next
Mike Rylander (mrylander) wrote :

I'd considered pulling this into 2.11 since it addresses some issues with time display, but after thinking longer, I judge the risk too big for a released version. This is especially true because it will require a new feature release of OpenSRF.

So, this will end up in Evergreen.next ...

Jason, thank you for testing!

Kathy Lussier (klussier) wrote :

I tested this branch using a client with a time zone of EST and a server with a time zone of Asia/Chita. I performed various check in, check out, and billing transactions in both the xul and web client. The time zone was stored properly in the database, and the expected due dates, checkin dates, checkout dates, etc. displayed as expected in the client and catalog.

It appears to address the issues identified in bug 1437109, but I want to do some more testing in the web client before I close that bug.

Merged to master for inclusion in 2.12.

Thank you Mike, Galen and Jason!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 2.next → 2.12-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers