authority data may be deleted during propagation with current values of authority.control_set_authority_field

Bug #1484281 reported by Yamil on 2015-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Critical
Unassigned
2.7
Critical
Unassigned
2.8
Critical
Unassigned

Bug Description

Since subfield $e in bib tags 100/110/600/610/700/710 is no longer
being used for auth linking through authority_control_fields.pl.in,
but we currently left it $e in authority.control_set_authority_field
rows for tag 100 (etc.), then the $e will be removed in the bib side
during future authority propagation. That is not a desired outcome.

New values need to be set for
Open-ILS/src/sql/Pg/950.data.seed-values.sql

 as well as an upgrade script.

Also a pgTAP test.

Note: this bug was discovered through working on LP bug 1465830:

presence of relator terms or codes in $e or $4 can prevent authority headings linking
https://bugs.launchpad.net/evergreen/+bug/1465830

Yamil (ysuarez) on 2015-08-12
description: updated
Remington Steed (rjs7) on 2015-08-20
Changed in evergreen:
importance: Undecided → High
milestone: none → 2.9-rc
status: New → Confirmed
importance: High → Critical
Yamil (ysuarez) on 2015-08-20
Changed in evergreen:
assignee: nobody → Yamil (ysuarez)
Yamil (ysuarez) wrote :

Here is my working branch so far...

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ysuarez/lp1465830_fix_auth_data_propagation_deletes

Still needs upgrade code, which I hope to learn how to do. Also, I need to fix the changes on file...
Open-ILS/src/sql/Pg/950.data.seed-values.sql

on commit d8cfdb88d06c15bc5404a188733aa101005a96f4

The new editor I used screwed up all the line endings, and thinks the whole file was changed.

I guess I need to recreate the commits, and maybe a new branch since there is a commit after the bad one already.

Yamil (ysuarez) wrote :

I just fixed the commit with the bad line endings and created the upgrade script.

I still want to rebase and squash this and create a proper commit message based on the new standard, but I wanted to get some feedback for my work so far.

(still the same working branch)

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ysuarez/lp1465830_fix_auth_data_propagation_deletes

Thanks in advance,
Yamil

Changed in evergreen:
assignee: Yamil (ysuarez) → Jason Stephenson (jstephenson)
Yamil (ysuarez) wrote :

I just added release notes / upgrade notes in case users have more than one authority control set.. Thanks to Dyrcona for the feedback.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ysuarez/lp1465830_fix_auth_data_propagation_deletes_rebased

Jason Stephenson (jstephenson) wrote :

Thanks, Yamil for the fix.

Pushed to master, rel_2_8, and rel_2_7!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
Yamil (ysuarez) wrote :

Just wanted to confirm that based on the documentation that I compiled with my catalogers, subfield $e should be authority controlled in auth tag 111, and therefore in bib tags 111/611/711 (maybe 811 too?)

Therefore I *think* in file Open-ILS/src/sql/Pg/950.data.seed-values.sql the entry for 111 in the authority.control_set_authority_field inserts, should continue to have an entry for subfield $e.

Those that know the authority code better than me might think otherwise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers