create_release_notes.sh include .adoc files

Bug #1482336 reported by Josh Stompro on 2015-08-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

The create_release_notes.sh script under /docs/RELEASE_NOTES_NEXT looks like it limits to gathering *.txt files in a few locations. Since DIG is looking to move to using the .adoc extension, that script needs to be updated to handle both *.txt and *.adoc.

It outputs a .txt file also, which will probably need to be changed to .adoc for consistency. Maybe the first step should just be to support sections written with the .adoc format.

http://git.evergreen-ils.org/?p=Evergreen.git;a=blob;f=docs/RELEASE_NOTES_NEXT/create_release_notes.sh;h=47d6e7ddb11632ebd1dd7b9415e26d3049a109f9;hb=HEAD

Josh

user/stompro/lp1482336_adoc_release_notes

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1482336_adoc_release_notes

Branch that adds adoc as a valid extension for release notes, also changes release notes output to .adoc.

Josh

tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

Question: Why use .adoc, when most other projects/places that use asciidoc for documentation use .asciidoc?

Dan Scott (denials) wrote :

Because .adoc is shorter, recognized and rendered by Github, and DIG would like to use it.

Jason Stephenson (jstephenson) wrote :

All right. I didn't realize that GitHub recognized also recognized .adoc. Seeing .asciidoc on a couple of GitHub projects is what prompted me to ask.

Galen Charlton (gmc) on 2015-11-04
Changed in evergreen:
milestone: none → 2.next
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

After speaking with Yamil, I've pushed this to master, along with a follow-up changing the extension of the release note template and existing release notes snippets in master. Thanks, Josh!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
milestone: 2.next → 2.10-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers