Stat cats are not displaying in statistical categories editor

Bug #1477677 reported by Kathy Lussier on 2015-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

Evergreen version: 2.8.1 and 2.8.2

The statistical categories editor is no longer displaying any statistical categories. We have confirmed that the stat cats are present in the database and can also see them in the item attribute editor and patron registration form.

This bug prevents our end users from creating new stat cats (since you need to see them stat cat to add the individual entries) and from modifying existing ones.

Marking the bug as confirmed based on confirmation from Erica Rohlfs in IRC.

Kathy Lussier (klussier) wrote :

We're also seeing the following error in the JavaScript Console:

Timestamp: 07/23/2015 01:20:37 PM
Error: TypeError: cat.sip_field() is null
Source File: oils://remote/xul/2015_06mlnc4_30_111633/server/admin/stat_cat_editor.js
Line: 214

Jeff Davis (jdavis-sitka) wrote :

We ran into this during our upgrade to 2.8. The top commit in the following branch contains our fix:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1477677-stat-cats-not-visible-in-editor

Ben Shum (bshum) wrote :

Fix works for me. Pushed to master and rel_2_8.

Thanks Jeff!!

Changed in evergreen:
milestone: none → 2.8.3
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers