Vandelay does not display all authority matches

Bug #1472380 reported by Bill Erickson on 2015-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.8
Undecided
Unassigned

Bug Description

Evergreen 2.8.

See also bug #1171984, which included a number of Vandelay authority record display fixes.

Steps to reproduce:

1. Export an authority record from Evergreen (so that it contains a 901c).
2. Create a "normalized heading" authority record match set (or any other match set that guarantees a match)
3. Import the previously exported record using your new match set.
4. 2 matches will be created, one from the match set and one on the 901c (identifier) value.
5. The authority queue grid will display "Matches (2)", but clicking on the link will only show 1 row in the match grid.

A similar scenario with bib records, where 2 matches against the same catalog record occur, results in 2 rows in the match grid, one for the 901c value and one for other match value.

Patch en route to show all matches in the authority match grid.

Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 2.9-alpha
tags: added: pullrequest
Changed in evergreen:
milestone: 2.9-alpha → 2.9-beta
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 2.9-beta → 2.9.0
Changed in evergreen:
status: New → Confirmed
Jason Stephenson (jstephenson) wrote :

Awesomesauce! Works for me.

Pushing to master and rel_2_8.

Thanks, Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers