When editing copy level information within a selection list (in Acq), a Fund cannot be chosen or assigned.

Bug #1463166 reported by Dale Rigney
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.12
Low
Unassigned

Bug Description

Verified in 2.6.3 and 2.7.4. If you create a selection list, click on the copies link. The copy level screen will not populate the fund drop down menu for added copies, nor will it let you type in a fund. You can select a fund on the batch menu line but when you try to apply that choice to the copies nothing shows in the fund box.

Work around is to create a purchase order from the selection list and then select funds.

Revision history for this message
Erica Rohlfs (erohlfs) wrote :

Confirmed in versions 2.7.4 and 2.8.1. Additionally, when attempting to apply a distribution formula that contains a fund, the fund value does not populate on the copies.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Liam Whalen (whalen-ld) wrote :

I have a fix for this. We are currently running it on production. It has a side effect of adding a Batch Updater to the Selection List screen (not the copies screen). However, in our testing, the org unit drop down in this new Batch Updater is not working. It is on my TODOs to fix that as well.

Here is my working branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ldw/LP1463166_Selection_List_No_Funds

tags: added: pullrequest
Revision history for this message
Kathy Lussier (klussier) wrote :
tags: added: signedoff
Revision history for this message
Kathy Lussier (klussier) wrote :

I'm removing the signedoff and pullrequest tag on this one because of the problem Liam previously noted with the org unit dropdown. Not only does it affect the org unit dropdown in the new batch updater, but, in my testing, it also impacted the selector in the main PO interface, which would be particularly problematic for users.

Liam, it appears to be a permission issue. I don't have a problem using the dropdown when I'm logged in as a superuser. I'll try to poke at it today too.

A more general question. Liam's branch fixes the reported bug, which is worthy of backporting, but it also has a new feature quality with the addition of the batch updater to the selection list. When the problem with the org unit selector is worked out, is it okay to backport it since it has a bug fix or should we only merge it to master for inclusion in 2.10?

I'm inclined to backport since the fund selector bug is a problem for those using selection lists.

tags: removed: pullrequest signedoff
tags: added: needsrepatch
Revision history for this message
Galen Charlton (gmc) wrote : Re: [Bug 1463166] Re: When editing copy level information within a selection list (in Acq), a Fund cannot be chosen or assigned.

On Tue, Nov 17, 2015 at 10:12 AM, Kathy Lussier
<email address hidden> wrote:
> A more general question. Liam's branch fixes the reported bug, which is
> worthy of backporting, but it also has a new feature quality with the
> addition of the batch updater to the selection list. When the problem
> with the org unit selector is worked out, is it okay to backport it
> since it has a bug fix or should we only merge it to master for
> inclusion in 2.10?

Not commenting on the specific patch here, but in general, if a bugfix
is most conveniently made in a way that effectively adds a small new
feature by activating a new path to existing code, I think it is
reasonable to backport it. (Provided, of course, that the new feature
actually works; backporting TODOs should of course be avoided.)

Revision history for this message
Liam Whalen (whalen-ld) wrote :

I have pushed a fix to a new working branch here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ldw/LP1463166_Selection_List_No_Funds

This returns the OUs to the owning branch drop down.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

We've had the final patch running on our live server (2.8) since the beginning of December with no issues reported so far.

Revision history for this message
Bill Erickson (berick) wrote :

Confirmed Liam's patch allows funds to be applied from the selection list page.

Looks like this issue also affects the 'View/Place Orders' and 'MARC Federated Search' entry points for creating orders. Looking at those..

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

New branch pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1463166-review

1. I squashed Liam's 2 commits into 1, since the second was a fix for the first.

2. Includes sign-off for Liam's commit.

3. Adds a new commit to support applying funds to copies for lineitems accessed from the View/Place Orders and MARC Federated Search interfaces. In both of these cases, the batch updater had to be initialized to activate the fund selectors (as with Liam's patch), but I opted to hide the batch widgets since the batch updater as a whole is not fully integrated into these 2 interfaces.

To test, perform a MARC federated search (for title=piano in concerto), click the copies(0) link on one of the results and confirm a fund can be applied to individual copies.

tags: added: acq pullrequest
removed: needsrepatch
Changed in evergreen:
milestone: none → 3.0-alpha
assignee: Bill Erickson (berick) → nobody
Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_12. Thanks, Liam and Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers