Account Expiration Date in My Account

Bug #1454879 reported by Terran McCanna on 2015-05-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Our patrons have requested the ability to see their account expiration date in the My Account section of the OPAC so that they can tell that their account is about to expire before it expires.

I've added code and will post it for review shortly.

Evergreen 2.7, 2.8

Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Terran McCanna (tmccanna) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
Ben Shum (bshum) wrote :

Looks good so far, after some consideration, this definitely sounds like a helpful new feature for future Evergreen. I'm targeting it initially towards 2.next.

Also adding a "needsreleasenote" tag to indicate that we should write up a brief statement about this new information display for the next release notes.

tags: added: needsreleasenote
Changed in evergreen:
milestone: none → 2.next
importance: Undecided → Wishlist
status: New → Confirmed
Changed in evergreen:
assignee: nobody → Josh Stompro (u-launchpad-stompro-org)

Just tested this out and it works just as described.

I have tested this code and consent to signing off on it with my name,Josh Stompro and email address, <email address hidden>.

tags: added: signedoff
Changed in evergreen:
assignee: Josh Stompro (u-launchpad-stompro-org) → nobody
Ben Shum (bshum) wrote :

This still needs a release note entry. I tagged it as a new feature, not a bug fix, because it adds new strings (that require translation).

Retargeting for consideration for 2.9 series.

Changed in evergreen:
milestone: 2.next → 2.9-alpha
tags: removed: signedoff
Terran McCanna (tmccanna) wrote :

Thanks, Ben!

Ben Shum (bshum) wrote :

I added a release note for this work to the OPAC section of the release notes, and have pushed it to master for inclusion as part of 2.9.

Cheers Terran! And thanks Josh for testing too.

Changed in evergreen:
status: Confirmed → Fix Committed
tags: removed: needsreleasenote
Terran McCanna (tmccanna) wrote :

Thanks so much Ben & Josh!

Changed in evergreen:
milestone: 2.9-alpha → 2.9-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers