Amnesty Mode doesn't work correctly with Backdating

Bug #1444514 reported by Thomas Berezansky on 2015-04-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.7
Medium
Unassigned
2.8
Medium
Unassigned

Bug Description

Currently Amnesty Mode does not work correctly with backdating. Instead of voiding all overdue fees it will only override to the backdate date, which is what backdating would do normally, but with the amnesty note attached.

I believe the change in this branch is all that is needed to ensure that amnesty mode ignores the backdate date when voiding overdues:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/tsbere/amnesty_overrides_backdate

Michele Morgan (mmorgan) on 2015-06-08
Changed in evergreen:
assignee: nobody → Michele Morgan (mmorgan)
Changed in evergreen:
status: New → Confirmed
Michele Morgan (mmorgan) wrote :

Tested this and it works as described. When a backdate is set in Checkin AND the Amnesty Mode circulation modifier is enabled, all fines on the transaction are voided and rows in money.billing.note are annotated appropriately with "Amnesty Checkin". So Amnesty Mode is appropriately overriding a backdate.

My signoff branch is here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mmorgan/lp1444514_amnesty_mode_overrides_backdate_signoff

Changed in evergreen:
assignee: Michele Morgan (mmorgan) → nobody
Changed in evergreen:
milestone: none → 2.9-alpha
Changed in evergreen:
importance: Undecided → Medium
Michele Morgan (mmorgan) on 2015-06-18
tags: added: signedoff
Changed in evergreen:
milestone: 2.9-alpha → 2.9-beta
Ben Shum (bshum) wrote :

Bleh, so this doesn't apply cleanly anymore because of other changes in master and needs rebasing.

The original code applies cleanly to rel_2_8 and rel_2_7 though...

So, I'm going to push the fix with mmorgan's signoff there for the maintenance releases tomorrow, but will coordinate further with tsbere, etc. to get a rebased version for master shortly thereafter for 2.9-beta+

Thomas Berezansky (tsbere) wrote :

I pushed a rebased branch that I believe fixes this in master now.....though I will admit to not having tested said change this morning, just made sure it was valid perl.

Ben Shum (bshum) wrote :

Thanks! I've pushed the new variant to master and we can hopefully see this resolved now.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers