Remove Biblios from the default Z39.50 targets

Bug #1441634 reported by Dan Scott on 2015-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

* Evergreen master

The Z39.50 target for biblios.net (at z3950.biblios.net:210/bibliographic) hasn't been functioning for years now. We should remove it from the seed data.

Dan Scott (denials) wrote :
Changed in evergreen:
milestone: none → 2.next
tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

Would we want an upgrade script to also remove it from existing installations, or would a release note with instructions on how to remove it be sufficient?

Changed in evergreen:
status: New → Confirmed
Dan Scott (denials) wrote :

I don't like to touch configuration data in existing installations during upgrades if I can help it. I guess we could add a release note telling sites to consider removing the entry for biblios, but it seems like the sort of thing that most sites would have removed already anyway once they realized that the site never returns any results.

Galen Charlton (gmc) wrote :

Since the biblios.net Z39.50 target is broken in a such a way as to not slow down or hang Z39.50 searches initiated by Evergreen, it causes no harm if a library has it in their configuration. Consequently, I agree with Dan that it's not necessary to remove the definition from existing installations. I'm 0 on whether to bother with a release notes entry.

Jason Stephenson (jstephenson) wrote :

Well, I'm in favor of a release note. We still have it configured and if it wasn't for this bug and IRC discussion today, I would not have known it was no longer working.

Kathy Lussier (klussier) wrote :

+1 to a release notes entry.

Galen Charlton (gmc) wrote :

Fair enough. I'll grab this and test and push Dan's patch and add release notes.

Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
importance: Undecided → Critical
importance: Critical → Low
Galen Charlton (gmc) wrote :

Pushed to master and rel_2_8. Thanks, Dan!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Ben Shum (bshum) wrote :

Changing milestone settings so that this bug fix can be closed when
2.8.1 is cut and released.

Changed in evergreen:
milestone: 2.next → 2.8.1
no longer affects: evergreen/2.8
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers