Audience filter no longer searching blank spaces

Bug #1414112 reported by Terran McCanna on 2015-01-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.6
Medium
Unassigned
2.7
Medium
Unassigned

Bug Description

We (PINES) just upgraded to 2.7.2 and filtering by the audience filter (either through the Advanced Search screen or by typing it in as audience(x)) is now ignoring blank spaces.

This was a problem with older versions of Evergreen (see https://bugs.launchpad.net/evergreen/+bug/760890) but was working for us in 2.5. Mike Rylander suggested opening a new bug since the underlying code that handles audience changed with the 2.6-era record attribute functionality.

Our advanced search filter for Adult is coded to search for " ,e,f,g" (blank space, e, f, and g) but it is only returning results for e, f, and g. As most of our adult items are coded with a blank space, this is an enormous problem!

Doing a keyword search for a keyword with the audience specifically blank also returns no results - for example: patterson audience( )

We searched NC Cardinal's OPAC because they are running 2.6 and it is not working there either.

Galen Charlton (gmc) wrote :

I have pushed a patch to the user/gmcharlt/lp1414112_allow_spaces_as_ff_attr_values branch in the working/Evergreen repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1414112_allow_spaces_as_ff_attr_values

tags: added: pullrequest
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.next
importance: Undecided → Medium
milestone: 2.next → 2.8-beta
Mike Rylander (mrylander) wrote :

I've added a reingest-free update to the search metadata, and protection for upgraded DBs that might have a blank instead of a space for "uncoded" audience. Also signed off on Galen's commit:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/miker/lp1414112_allow_spaces_as_ff_attr_values

Elaine Hardy (ehardy) wrote :

Chris and Terran are both out today but as soon as we can, we will get this on a test server and get it tested.

Thanks for the quick work on this!

Elaine

Chris Sharp (chrissharp123) wrote :

I found an error in the second UPDATE command in the upgrade script. Corrected and signed-off here:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/lp1414112_allow_spaces_as_ff_attr_values

Elaine Hardy (ehardy) wrote :

We were able to test today and the audn filter now functions as expected. Thank you!

Ben Shum (bshum) wrote :

Pushed to master and backported to rel_2_7 and rel_2_6.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers