TPAC: Towards more meaningful, contextual page titles

Bug #1409844 reported by Dan Scott on 2015-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

* Evergreen master

Currently the catalogue <title> elements are formed by concatenating the page title to "Catalog - ". This means that on browsers with more than a few tabs open, users will only see "Catalog -", which doesn't help them navigate their tabs. Also, in search results in general search engines, "Catalog - " is expected to be a significant word as it appears first in the title of the page.

Instead, let's remove the "Catalog - " prefix entirely and add "- <library name>" as a suffix to the page title. That way, a user will see the page title in bookmarks, search results, and other contexts with the most important information up front (whether that's the title of the work in record details, or the fact that it's a search for some string), followed by the name of the library to give it a specific context.

In addition, use the name of the library in the OpenSearch definition to be more meaningful than the current hardcoded "Evergreen OpenSearch" (many users will not even know what Evergreen is, if they stumble across the little "Add search engine" widget at all).

And finally, use the HTML and URI filters appropriately to avoid any possible damage :)

Dan Scott (denials) on 2015-01-12
tags: added: discoverability pullrequest
Changed in evergreen:
milestone: none → 2.8-beta
Dan Scott (denials) wrote :

See http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbs/lp1409844_library_name_title for a branch containing the relevant commit. We're running this in production on top of 2.7.

Ben Shum (bshum) wrote :

Works for me, signing off for now, but waiting the requisite 1 week period for further review before pushing on to master.

Signoff: user/bshum/lp1409844_library_name_title

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/lp1409844_library_name_title

Changed in evergreen:
status: New → Confirmed
Ben Shum (bshum) wrote :

Pushed to master for new 2.8 goodness. Thanks Dan!

Changed in evergreen:
status: Confirmed → Fix Committed
importance: Undecided → Wishlist
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers