reporter IDL getting confused with DEFLATE

Bug #1407171 reported by Bill Erickson on 2015-01-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.6
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

Ubuntu 14.04 / Evergreen master (circa 2.7)

This is another instance of the issue described in bug #652343

Fetching /reports/fm_IDL.xml via browser / staff client fails with an internal server error in Apache. The problem is that we are running a DEFLATEd file through IDLCHUNK. Presumably, the mod_deflate default configuration in 14.04 applies the filter more liberally.

The solution is the same as the one proposed in #652343. Patch en route.

Bill Erickson (berick) wrote :
Changed in evergreen:
milestone: none → 2.8-beta
assignee: Bill Erickson (berick) → nobody
tags: added: pullrequest
Ben Shum (bshum) wrote :

Sounds good, pushed to master and backported to rel_2_7 and rel_2_6.

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers