Merge parts functionality fails to preserve copy_part mapping

Bug #1406786 reported by Michele Morgan on 2014-12-31
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.7
Undecided
Unassigned
2.8
Undecided
Unassigned
2.9
Undecided
Unassigned

Bug Description

The Merge Monograph Parts functionality new in 2.7 does not preserve the copy/part mapping for the deleted part.

Here's the original launchpad bug:

https://bugs.launchpad.net/evergreen/+bug/1099979

and the commit:

http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=8f4d3efb029f109d3dc7dc69cf458c2834c725d6

When selected parts are merged in the Manage Parts interface in the client, the user chooses a "prevailing item", which is the part to be preserved. The remaining selected parts are deleted when the user clicks to choose the prevailing item.

Any copy that was mapped to the deleted parts, loses its part mapping rather than having the mapping updated to the prevailing part.

It looks like a row is being deleted from asset.copy_part_map rather than being updated with the prevailing part's id.

Updating this mapping is essential to using this functionality.

Mary Llewellyn (mllewell) wrote :

Yes, we've seen this happen, too. I've been pointing the item to the desired part prior to merging the parts, just to avoid running into the deletion.

Ben Shum (bshum) wrote :

Marking bug as confirmed.

tags: added: cataloging parts
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Michele Morgan (mmorgan) on 2015-10-28
description: updated
Galen Charlton (gmc) on 2015-10-29
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) on 2015-10-29
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1406786_move_copy_maps_during_parts_merge branch in the working/Evergreen repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1406786_move_copy_maps_during_parts_merge

tags: added: pullrequest
Dan Pearl (dpearl) wrote :

I had a fix for this, but Galen's change is smaller. Thanks, Galen!

Changed in evergreen:
assignee: nobody → Dan Pearl (dpearl)
assignee: Dan Pearl (dpearl) → nobody
Galen Charlton (gmc) wrote :

Yeah, Kathy mentioned that we were poking around the same area of code. Mind testing and signing off on my patch, Dan?

Dan Wells (dbw2) on 2015-11-04
Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
Dan Wells (dbw2) wrote :

Looks good, works great. Pushed to master and all active versions. Thanks, Galen!

Changed in evergreen:
milestone: none → 2.next
status: Confirmed → Fix Committed
assignee: Dan Wells (dbw2) → nobody
Changed in evergreen:
milestone: 2.next → 2.10-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers