Results of a metarecord search will display duplicate format icons

Bug #1401177 reported by Kathy Lussier on 2014-12-10
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.6
Medium
Unassigned
2.7
Medium
Unassigned

Bug Description

Evergreen version 2.7.1

The search results page for a metarecord search is now displaying duplicate icons when there are multiple titles of the same format in the same metarecord group.

See http://egtraining.noblenet.org/eg/opac/results?query=harry+potter+order+phoenix&qtype=keyword&fg%3Aadvanced=&locg=1&sort=&modifier=metabib

The expectation is that the search results will only display one-icon-per-format in the metarecord group. This was working as expected in 2.6.2.

See http://evergreen.noblenet.org/eg/opac/results?query=harry+potter+order+phoenix&qtype=keyword&fg%3Aadvanced=&locg=1&sort=&modifier=metabib

Changed in evergreen:
status: New → Confirmed
Ben Shum (bshum) wrote :

We've traced this to changes made in bug 1374091, specifically this commit in master (http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=04d618aa860afbcd90d8dcfb57c7f26cb433bb2e).

It looks like when we changed that function to improve performance, it made it no longer a distinct lookup. So it would show all icons for each bib.

Thanks to Jason for helping me test and confirm this issue.

Mike indicated in IRC a fix is forthcoming for this.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers