Ability to Record Split Hours of Operation

Bug #1396764 reported by Jennifer Pringle
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

Wishlist

Evergreen 2.6

Currently on the Hours of Operation tab in Organization Units (Admin -> Server Administration -> Organizational Units) you can only enter one Open Time and one Closed Time for each day. Some of our libraries close for multiple hours in the middle of the day and then re-open in the evening.

It would great if you could add additional Open and Closed times to a day of the week so that you could reflect your real open and closed hours.

Kathy Lussier (klussier)
Changed in evergreen:
status: New → Triaged
importance: Undecided → Wishlist
Revision history for this message
Lindsay Stratton (lstratton) wrote :

Pioneer also would love to see this functionality. We have many libraries with split hours, and with the library information linked and able to display in the catalog we are very concerned about the risk of misleading information being displayed to patrons. (v.2.7)

Elaine Hardy (ehardy)
tags: added: orgunitsettings webstaffclient wishlist
Elaine Hardy (ehardy)
tags: added: admin-pages
removed: orgunitsettings
Revision history for this message
Carrie Cleary (ccleary.pails) wrote :

This would also be a feature needed for locations who alternate days of the week they are open, like those who are open only every other Sunday or 1st and 3rd Sunday or for a location who is open every other Friday and every other Saturday on alternating schedule. Not all library schedules conform to regular hours.

Revision history for this message
Joan Kranich (jkranich) wrote :

C/W MARS would find this functionality helpful for libraries with split schedules. It would be good to incorporate summer and winter hours as well. Most of our libraries have a different summer schedule.

Revision history for this message
Allison Midgley (midgleya) wrote :

A limited character note about hours would be a helpful feature, so libraries that have closed their buildings could let patrons know about curbside pickup hours.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

+1 to a note that can accompany the hours

Revision history for this message
Terran McCanna (tmccanna) wrote :

+1 to the note - I thought there was already a different bug for that, but I can't find one now.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

+1 to the note.

tags: removed: webstaffclient
Changed in evergreen:
status: Triaged → Confirmed
Revision history for this message
Ruth Frasur (rfrasur) wrote :

I've been working on putting together requirements for this but have, so far, only had time to put together mockups for interfaces. This first shows the modified hours form in org unit settings when there are no split hours.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

This shows the ability to add split hours for a specific day as well as add a note.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

And, finally, how this would display in the OPAC.

Revision history for this message
Joan Kranich (jkranich) wrote :

Thanks Ruth. I would like the public display of the note to be optional. If not then we probably would not add many notes which is okay. I am also thinking of the display on our app and on a mobile display.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

These look great Ruth!

I agree with Joan, it would be helpful if the notes could be staff or public. I could see a note like "Switch to fall hours on October 1st" being useful for staff and but not so much for patrons.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

Joan, I agree. I think this could "easily" be a library setting since it's a true/false thing.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

Or, it could also be another tick box in the org unit hours editor.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

For a third option, it could be an Add Note button that opens a pop up like in the Holdings Editor.

Revision history for this message
Ruth Frasur (rfrasur) wrote :

That would be cool. There would still need to be a way to designate the note as publicly viewable or not. Additionally, if there was a note created for the a day, perhaps it could cause an EDIT button to activate indicating that there was an active note.

Revision history for this message
Joan Kranich (jkranich) wrote :

Another tick box in the org unit hours editor is preferred. This would allow some notes to be public and some to be for staff.

tags: removed: wishlist
Kyle Huckins (khuckins)
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Revision history for this message
Kyle Huckins (khuckins) wrote (last edit ):

I have a branch here that addresses the split hours feature: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/khuckins/lp1396764-split-hours-of-operation

While working on this, I noticed that the Hours of Operation IDL object is very unwieldly, in desperate need for a refactor. That would have to be its own undertaking, though, as it would require significant changes in how the OPAC reads serves the information. I think a bug covering a refactor might be the best place to add the notes feature.

Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
tags: added: pullrequest
Revision history for this message
Ruth Frasur (rfrasur) wrote :

Kyle, could you submit that ticket since you have the best understanding of what it should say?

Revision history for this message
Kyle Huckins (khuckins) wrote :

I've just submitted a bug report here: https://bugs.launchpad.net/evergreen/+bug/1960535

Revision history for this message
Terran McCanna (tmccanna) wrote :

I put this up on a test server for feedback fest next week.

My initial note is that the time selectors don't let you choose AM/PM so the resulting behavior is not what I expected. For example, I entered these times for a Monday:

8:30 - 11:30 in the first block
12 - 5 in the second block

And I got this output on the library info page:

Monday: 8:30 AM - 11:30 PM ; 12:00 AM - 5:00 AM

Revision history for this message
Gina Monti (gmonti90) wrote :

Can confirm something similar to Terran's comment. Changed Monday hours to 8:30 AM to 11:30 AM, 1:00 PM to 5 PM. Output is:

8:30 AM to 11:30 PM, 1:00 AM to 5 :00 PM

Revision history for this message
Joan Kranich (jkranich) wrote :

I know there is already a sign off -thanks! - but I was curious about the AM/PM. I am finding on the test server that entering the AM or PM is working fine.

Revision history for this message
Terran McCanna (tmccanna) wrote :

A-ha! I just tried it again and realized it's a window and field size display issue. The AM/PM options are actually there, but not visible unless your window is open really wide. Attached screenshot of what it looks like at my normal size working window - you can see that the AM/PM doesn't show up.

To resolve, I think the field width just needs to be forced to accommodate the contents.

tags: added: needswork
removed: pullrequest
Revision history for this message
Lindsay Stratton (lstratton) wrote :

I tested with minimized screen widths -

At a moderately small width (ex: 1150x882), clicking the clock icon in date selection box opens an expanded time selector which includes AM/PM.

At a mobile-type width (ex: 393x851), the time fields stack vertically, fully displaying both ranges and AM/PM.

Revision history for this message
Terran McCanna (tmccanna) wrote :

The clock icon works okay for Chrome, but it does not exist in Firefox. Firefox shows an "X" icon which clears the field contents (see screenshot in comment #25). I haven't tested any other browsers, but the behavior needs to be the same regardless of which browser is being used.

Revision history for this message
John Amundson (jamundson) wrote :

I just want to note that the "missing" clock in Firefox doesn't seem like it's related to this bug fix. I'm attaching a screenshot of our test server running Evergreen 3.7 without this patch installed.

Note how in Chrome the clock appears, but it doesn't appear in Firefox.

Since this is browser related, I don't think it should stop this patch from getting committed.

Revision history for this message
Terran McCanna (tmccanna) wrote :

The difference is that in 3.7 the AM/PM option displays regardless of screen size and browser. This patch, as-is, reduces the current usability and could easily lead to data errors. I'm not comfortable signing off until that is corrected.

Kyle Huckins (khuckins)
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Revision history for this message
Lindsay Stratton (lstratton) wrote :

Is this still on a test server? I'm curious about other browsers. For example one of my libraries uses Vivaldi.

Revision history for this message
Kyle Huckins (khuckins) wrote :

I've done a quick rebase, and pushed an additional commit to widen the date fields

Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
Revision history for this message
Terran McCanna (tmccanna) wrote :

Thanks Kyle, I'll get it up on a test server.

tags: added: pullrequest
removed: needswork
Revision history for this message
Terran McCanna (tmccanna) wrote :

The wider fields are much better!

Revision history for this message
Terran McCanna (tmccanna) wrote :

This works as expected now - thanks! (Noting that if you put in times that don't make any sense, the display on the library info page will reflect that, but it doesn't appear to break anything as far as I can see.)

My sign off at:
https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1396764-split-hours-of-operation-signoff

Revision history for this message
John Amundson (jamundson) wrote :

Has anyone had a chance to test the changes against hourly loans and curbside?

I just added split hours for BR4 on Thursday and Friday, enabled Curbside at BR4, and went to schedule a curbside pickup. The only option for Thursday and Friday hours were in the first hour set of the split. I didn't get options from the second split.

I'm not convinced that this should stop this from getting pushed, but it will need its own bug/investigation after the fact.

Revision history for this message
Kyle Huckins (khuckins) wrote (last edit ):

The code behind hourly loans and curbside pickup will likely need to be taught about the new date fields in order to work with them. Ideally, any implementation of bug 1960535 will need to take those interfaces into account as well

Revision history for this message
John Amundson (jamundson) wrote :

If/once this gets committed, I'll open up a new bug about curbside/hourly. The way I see it, the new split hours doesn't take away functionality. Split hours just can't be added if curbside/hourly is a priority for that day.

Revision history for this message
Mike Rylander (mrylander) wrote :

I have to strongly disagree with pushing this knowing that two existing features are broken by it. There's still time to address curbside and hourly loans directly, but another option would be to instead create (for now) display-only lunch_start and lunch_end fields to create a "hole" for the library details page to show.

Separately, I notice that the upgrade script seems out of sync with the baseline schema in that some of the new fields are nullable and some are not. Is there a reason for that difference?

Thanks, and, sorry! :)

Revision history for this message
Jason Boyer (jboyer) wrote :

Adding support for split hours of operations means adding *support* for them, making an effort to find and update places in the code where hours of operation are consulted. From a quick glance of the patch I can tell that this primarily only affects the library hours display in the OPAC.

If a library has split hours and enters them correctly in this interface they will silently cause the system to ignore all second-segment hours when considering circulation / renewal due dates, hold targeting, curbside hours, emergency closure adjustments, and so on. Libraries that don't use those features may not care (until they very much do and it's too late) but as is locations with split hours are better off customizing their library hours opac templates until this feature can be more fully implemented.

For better or worse there is a reason this bug is so old; addressing it properly is going to be a lot of work.

Revision history for this message
John Amundson (jamundson) wrote :

"but another option would be to instead create (for now) display-only lunch_start and lunch_end fields to create a "hole" for the library details page to show."

I am in favor of this as a workaround until this can be more fully addressed. If implemented, ideally there would be a tooltip or note stating that the "hole" will only affect the display in the OPAC.

Revision history for this message
Terran McCanna (tmccanna) wrote :

I've long wished for a text field next to each date to be able to add notes such as "Open alternating Saturdays" or "Curbside only after 1pm" - so perhaps a temporary solution to the display problem would be to leave the hours as they were but then add a text field so that libraries can say "Closed for lunch from Noon-1pm"

tags: added: needswork
removed: pullrequest
Kyle Huckins (khuckins)
Changed in evergreen:
assignee: nobody → Kyle Huckins (khuckins)
Revision history for this message
Kyle Huckins (khuckins) wrote :

All good feedback, thanks everyone! I've pushed a branch here with a workaround: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/khuckins/lp1396764-hours-of-operation-note

This brings in Terran's idea - a note field has been added to the Hours of Operation object. This note field will be able to, as mentioned, note any mid-day closing hours, among other things.

Noting here and in bug 1960535, if merged, this fix will need to be taken into account in the proposed refactor of Hours of Operation as well

tags: added: pullrequest
removed: needswork
Changed in evergreen:
assignee: Kyle Huckins (khuckins) → nobody
Revision history for this message
Christine Burns (christine-burns) wrote :

I have tested this code and consent to signing off on it with my name, Christine Burns, and my email address, <email address hidden>

tags: added: signedoff
Changed in evergreen:
milestone: none → 3.10-beta
Michele Morgan (mmorgan)
Changed in evergreen:
assignee: nobody → Michele Morgan (mmorgan)
Revision history for this message
Michele Morgan (mmorgan) wrote :

Pushed to master for release 3.10.

Thanks Kyle, Christine, and all who weighed in.

I've summarized some comments from this bug on bug 1960535 so the discussion can continue there.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Michele Morgan (mmorgan) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers