action_trigger_runner.pl documentation update

Bug #1396161 reported by Josh Stompro on 2014-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.6
Undecided
Unassigned

Bug Description

I noticed that the --granularity-only argument no longer does anything, and that the --verbose argument wasn't documented.

The --granularity-only arg was changed to being always set if --granularity= is used back in 2010 by miker. It looks like this was done because the code was changed to use a different lock file when --granularity is used, so that multiple action_trigger_runner.pl instances for different granularity could run at the same time. But there might have been problems if each run also tried to process events without granularity, so granularity-only was locked to on whenever granularity was set. It makes sense, it was just never documented.

The --verbose argument adds some info about which hooks are being processed and what the granularity scope is, useful for debugging.

I'm going to add another example to the docs on how to use granularity.

There are a few places in the docs that use --granularity-only which I'll fix also.

https://github.com/evergreen-library-system/Evergreen/commit/59f94de22a06a1fc8f0ebc08839feff2f706aab7
https://github.com/evergreen-library-system/Evergreen/blame/master/Open-ILS/src/support-scripts/action_trigger_runner.pl.in#L61

Josh

Remington Steed (rjs7) on 2014-11-26
Changed in evergreen:
assignee: nobody → Remington Steed (rjs7)
Remington Steed (rjs7) wrote :

Here is my sign-off branch, plus an additional commit to update the public docs and edit the examples in the script.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/lp1396161_action_trigger_runner_docs

Changed in evergreen:
assignee: Remington Steed (rjs7) → nobody
status: New → Confirmed
tags: added: bitesize-doc pullrequest
Changed in evergreen:
milestone: none → 2.7.2

Remington, maybe we should change that "--granularity=Hourly" back to "--granularity=hourly" if the fix in bug 1205072 gets committed. Thanks for taking out the redundant parts.

Galen Charlton (gmc) on 2014-12-23
Changed in evergreen:
milestone: 2.7.2 → 2.7.3
Remington Steed (rjs7) wrote :

Josh, good suggestion to fix the docs for bug 1205072. However, since that bug already has release notes included, the Docs Interest Group (DIG) will update the docs appropriately when that bug fix is released. I added a comment to that bug about the script help text, though, so that part doesn't get missed. As for this bug, I think this branch is ready to go for 2.7 and earlier.

Remington Steed (rjs7) wrote :

I ran some basic tests on action_trigger_runner.pl with the patches applied, and it compiles and prints the help text properly.

Ben Shum (bshum) wrote :

Picked these to master, rel_2_7 and rel_2_6, thanks guys!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers