broken Journal Title search in 2.6.4

Bug #1392429 reported by Holly Brennan on 2014-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Two days ago we upgraded from 2.5.2 to 2.6.4. We also upgraded OpenSRF from 2.2.? to 2.3.0. PostgreSQL remained unchanged (9.1). I am now unable to pull up any records using Journal Title for search type, journals or not.

For example, I use Journal Title search type to check in the daily newspapers. Searching for "New York Times" gave me only one result, the daily newspaper New York Times. Now after the upgrade, I don't get any results from this same search. I can find "New York Times" when using a Title or Keyword search type... but then of course I get hundreds of hits for other "New York Times" publications.

This problem is true with all serials I've tried, newspaper and magazines.

Holly Brennan (hollyfromhomer) wrote :

There was a block of code we commented out during the upgrade, open ils ingest. We commented this out because it wasn't something that matched up, and Equinox support didn't know what it was either. This may be the issue, since journal records aren't showing icons....

OR, and I'm a bit rusty on cataloging, but our bib level in the MARC record for journals say 's', but right-clicking in this bib level field suggests 'e' for serial.

Dan Scott (denials) wrote :

open-ils.ingest is an old service that hasn't been necessary for many releases now; Evergreen does all of its ingest inside the database. So that can and should stay commented out.

Can you link to an example record that is a problem? I'm wondering if perhaps the bib level is offset by a space or the like.

Holly Brennan (hollyfromhomer) wrote :

Our catalog:
https://catalog.ci.homer.ak.us/eg/opac/home

Any journal will do: New York Times, Wall Street Journal, Alaska Dispatch News, Fine Homebuilding....

As mentioned above, I noticed our serial records have 's' as Blvl, but right-clicking offers 'e'... so I changed this on one one record, Alaska Dispatch News. Still doesn't pull it up with a Journal Title search.

Holly Brennan (hollyfromhomer) wrote :

Turns out this was a problem specific to our library. Here's info from Equinox, who helped get us back on track!

It looks like it's because you were missing some seed data on the config.coded_value_map table. The journal search does a bib search type of s, which was not in your coded value map. It's inserted under SQL script 950, but doesn't look to be part of any upgrades scripts.

Kathy Lussier (klussier) on 2014-11-14
Changed in evergreen:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers