Documentation: 2.7 upgrade docs need to be updated

Bug #1390138 reported by Josh Stompro on 2014-11-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

The 2.7 upgrade docs need to be updated, they are just a copy of the 2.6 upgrade docs currently.

http://docs.evergreen-ils.org/2.7/_upgrading_the_evergreen_server.html

http://git.evergreen-ils.org/?p=Evergreen.git;a=blob;f=docs/installation/server_upgrade.txt;h=3aee08de36799a79d81cf9d6b38a7c8db2d12a35;hb=master

I'll create a working collab branch and start making changes.

Josh

Changed in evergreen:
assignee: nobody → Josh Stompro (u-launchpad-stompro-org)

I found one more thing I missed in the update docs, so there is another commit for that.

Also, I added a fix to the updating the staff client docs about bulding the client.

I've successfully upgraded my 2.6.3 system to 2.7.1 using these instructions.

Josh

Ben Shum (bshum) wrote :

Looks pretty good so far. I might suggest some more variable instructions for copying the apache config files, given that we don't know if people will definitely be using apache or apache 2.4. Also, we may want to make a recommendation towards folks using newer PostgreSQL version 9.3 even though 9.1 is the minimum version allowed.

Thoughts or other suggestions?

Changed in evergreen:
milestone: none → 2.7.2
status: New → Confirmed
importance: Undecided → Medium

Ben, is Postgresql 9.2 usable also? How about 9.4beta, I see that seems to be the default in Jessie?

How about the debian pkgs from postgresql https://wiki.postgresql.org/wiki/Apt, should we add that to the docs instead of using squeeze backports like is documented now.

I'll add notes about 9.3 being the preferred version right now to the upgrade and install docs.

Josh

Ben Shum (bshum) wrote :

PostgreSQL 9.2 should be usable as well, though I have no direct experience myself. I have only used PG 9.3 recently. As for PG 9.4beta, I would probably not recommend use of beta software for the database in production use. Certainly I'd be curious to try it out later as a developer and to test future compatibility needs (thus far subsequently new versions of PostgreSQL tend to require some changes in Evergreen to support properly).

Squeeze backports instructions will only be needed as long as squeeze is supported. We can always switch to suggesting the PostgreSQL apt repos, they seem well tended by their community. That said, when next Debian (Jessie?) is released, I expect Squeeze support to go away from Evergreen. Latest and immediate past versions, etc.

If others have input/suggestions, this is good.

Ben, I addressed the issues you brought up for the Apache config files. I just added the same blurb that is at the top of the apache install docs about the different versions. Let me know if you think that is enough. I sort of want to go into the fact that if the example files haven't changed since the last dot release, nothing needs to be done. I hate to think of someone having to merge in their changes for each dot release for no reason. But maybe that is something we should expect someone to understand if they are at the point that they are regularly upgrading Evergreen.

I also added notes to both the install and upgrade docs about Postgresql 9.3 being the recommended version.

Like I mentioned on IRC. I think changing the docs to to have people use the Postgres apt repos should wait for later. I just want to get the upgrade docs out there so it no longer says "Comming Soon" on the download page.

Josh

Galen Charlton (gmc) on 2014-12-23
Changed in evergreen:
milestone: 2.7.2 → 2.7.3
Changed in evergreen:
assignee: Josh Stompro (u-launchpad-stompro-org) → nobody
tags: added: pullrequest

I updated the branch to make 2.7.3 the base version shown since this is targeted for 2.7.3. I just ran through the doc and did a 2.7.1 to 2.7.2 upgrade and I didn't notice anything out of place.

Ben Shum (bshum) wrote :

I rebased all your changes against present master and rel_2_7 (there was some minor conflicts due to drift from your collab vs. the main branches).

I also changed the upgrade path slightly to clarify the renamed file in newer versions and removed references to Ubuntu 10.04 Lucid because that is not a supported OS.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers