Need a more intuitive means of escape after clicking Advanced Hold Options

Bug #1373203 reported by Kathy Lussier on 2014-09-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.6
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

Evergreen version: 2.6+

If a user places a hold in the catalog and then clicks the "Advanced Hold Options" link, they have no way to get out of the Advanced Search options, other than to use the browser's back button, which is unintuitive. The resulting hold will then be a metarecord hold, even if the user didn't make any selections after clicking the link.

We need a way to get people out of here if they decide not to utilize any of the advanced search options.

Erica Rohlfs (erohlfs) wrote :

Hi Kathy!

My OPAC contains a "Cancel" button within the Advanced Holds interface. When I select Cancel, I am redirected back to the regular holds screen. However, I can see how the term Cancel may make users think they are cancelling the hold entirely.

Changed in evergreen:
status: New → Incomplete
Kathy Lussier (klussier) wrote :

Thanks Erica! I'm going to change the title of this bug report to improve the way we escape this area.

I have a screenshot of the current holds interface with the "Advanced Holds Options" displaying. http://www.screencast.com/t/RFNYQO0ERIZ

The cancel button is far down on the screen, is the same one that is typically used to cancel a hold, and, being located next to the "Place Hold" gives all appearances of being a "Cancel This Hold" button. I don't think most people would expect clicking the button would get them out of the "Advanced Hold Options." I also think that people who truly want to cancel placing the hold might get a little annoyed at having to click the "Cancel" button twice.

I think there are a couple of ways we could improve upon this:

* If nobody selects a format or language in the list, make it a title level hold. Right now on our system, it's automatically selecting "english," so I think we would need to change things so that everything is deselected.

* Provide some radio buttons at top to place hold on this record only or to accept alternate formats. Clicking on the latter enables the select menus. Clicking the former places the hold on the title.

* Maybe make the "Advanced Search Options" link a toggle. Clicking it once opens the page with the options. Clicking it again, closes the options again.

I'm open to other ideas. I couldn't quite remember how it worked in jspac, but we do recall there was an intuitive way to not place the meta record hold.

summary: - No way to escape after clicking Advanced Hold Options
+ Need a more intuitive means of escape after clicking Advanced Hold
+ Options
Changed in evergreen:
status: Incomplete → New
Erica Rohlfs (erohlfs) on 2014-09-24
Changed in evergreen:
status: New → Confirmed
Kathy Lussier (klussier) on 2014-12-12
Changed in evergreen:
importance: Undecided → Medium
Kathy Lussier (klussier) on 2015-02-21
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

After reading through the code while working on https://bugs.launchpad.net/evergreen/+bug/1423922, I had an aha moment on how to fix this bug. The branch at working/user/kmlussier/lp1373203-let-users-escape-metarecord-holds replaces the advanced hold options link with a basic hold options link that displays if a user stumbles into the metarecord hold options. Clicking the link brings them back to a title-level hold. The basic hold options link will NOT display if the hold starts off as a metarecord hold, mainly because we wouldn't know which bib id to use here.

The branch also fixes the issue noted above where clicking the cancel button brings the user back one screen instead of returning them to the screen they were on before clicking "Place Hold." This fix will also address an issue bshum discovered with the new "place another hold on the same title" link where use of the Cancel button would try to re-submit the hold that was just placed.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1373203-let-users-escape-metarecord-holds

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.8-beta
Ben Shum (bshum) wrote :

Picked this to master for 2.8+

For rel_2_7 and rel_2_6, I only grabbed the necessary bits for place_hold.tt2 and then modified the string change so that it used existing string language like "Go Back" (which exists in the translation files for TPAC). So for those versions, the backported version of this changeset is slightly different than 2.8+ where the new language reflects more accurately the purpose of the link.

Cheers, and thanks Kathy!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers