Email::Send is deprecated

Bug #1362260 reported by Galen Charlton on 2014-08-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

The Perl module Email::Send is deprecated in favor of Email::Sender (and has been for years):

https://metacpan.org/pod/Email::Send#WAIT-ACHTUNG

This came to my attention with the discovery that Debian testing no longer includes a libemail-send-perl package.

Options for a fix include:

[1] Switching to Email::Sender
[2] Just installing Email::Send from CPAN for Jessie.
[3] Do option #2 for the 2.7.0 release, then follow up with #1.

Evergreen master

Jason Stephenson (jstephenson) wrote :

It came to my attention recently, too. IIRC, I saw the messages in the logs when looking into something else.

Changed in evergreen:
status: New → Confirmed

Here is a working branch with the changes to switch from the no longer existing debian package to using cpan.
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/stompro/lp1362260-jessie-email-send-make

I'm testing with 2.8.0 and it seems to have worked fine.

Josh

tags: added: pullrequest
Nathan Eady (mrmcquack) wrote :

Now that jessie is officially released, users following the install instructions are getting an error from make due to this.

Ben Shum (bshum) wrote :

Picked to master and backported to rel_2_8 and rel_2_7 to provide better Debian Jessie support. Thanks Josh!

Changed in evergreen:
milestone: none → 2.8.2
status: Confirmed → Fix Committed
Ben Shum (bshum) wrote :

We may still want to pursue Galen's note about option 1 and reworking Evergreen to use the newer module.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers