Use -i in marc_export exclude records with located URIs.should at least include records with located URIs

Bug #1350916 reported by Francisco Guel on 2014-07-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

EG version: 2.6.0
Debian Squeeze

I were trying to export some records to marc using the marc_export file, but when I use the -i flag, I don´t get the marc records that have located URIs, Dyrcona told me that "the -i option to include item information excludes records without copies." but it should include the records with located URIs.

Thanks.

Regards

Changed in evergreen:
status: New → Triaged
importance: Undecided → Wishlist
tags: added: export marc uris
Jason Stephenson (jstephenson) wrote :

It's debatable if this is a bug or a missing feature, so I'm setting the importance to wish list. If others with the powers disagree, please change the importance.

I can confirm that if the -i (--items) options is specified in the post-2.6 marc export that only records with copies will be exported. The holdings export excludes records with located URIs as well as records without copies or URIs. This is true even if the --all (-a) option is specified.

It is open for discussion whether there should be an additional option to export URIs and/or empty records when --items is specified, or if those records should just be included when --items is specified.

As an added twist, records with asset.call_number entries will be exported if the --library option is used. The call number's owning_lib link is used to determine what records should be exported. This means that records with asset URIs may get exported if the --library option is used without the --items option. The --items option will stil prevent them being exported if --library is specified.

Jason Stephenson (jstephenson) wrote :

I propose resolving this by adding a new option to export records with located URIs. This option will be orthogonal to the --items option, so if you want both items and records with located URIs, then you will need to use both options.

Also, this new option will export all records with located URIs if the --library or --descendants options are omitted.

Changed in evergreen:
milestone: none → 3.next
assignee: nobody → Jason Stephenson (jstephenson)
Jason Stephenson (jstephenson) wrote :

My working branch is user/dyrcona/lp1350916-marc_export-located-uris :
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1350916-marc_export-located-uris

You wan the top two commits for release notes and the actual code.

I believe it is ready for testing/merging, and I have used it in production.

tags: added: pullrequest
Changed in evergreen:
assignee: Jason Stephenson (jstephenson) → nobody
milestone: 3.next → 3.1-beta

I was actually just thinking about this a few days ago (and then forgot
about it when the holiday hit) but I agree to the new option. +1

On Mon, Nov 27, 2017 at 3:53 PM, Jason Stephenson <
<email address hidden>> wrote:

> My working branch is user/dyrcona/lp1350916-marc_export-located-uris :
> http://git.evergreen-ils.org/?p=working/Evergreen.git;a=
> shortlog;h=refs/heads/user/dyrcona/lp1350916-marc_export-located-uris
>
> You wan the top two commits for release notes and the actual code.
>
> I believe it is ready for testing/merging, and I have used it in
> production.
>
>
> ** Tags added: pullrequest
>
> ** Changed in: evergreen
> Assignee: Jason Stephenson (jstephenson) => (unassigned)
>
> ** Changed in: evergreen
> Milestone: 3.next => 3.1-beta
>
> --
> You received this bug notification because you are subscribed to
> Evergreen.
> Matching subscriptions: evergreenbugs
> https://bugs.launchpad.net/bugs/1350916
>
> Title:
> Use -i in marc_export exclude records with located URIs.should at
> least include records with located URIs
>
> Status in Evergreen:
> Triaged
>
> Bug description:
> EG version: 2.6.0
> Debian Squeeze
>
> I were trying to export some records to marc using the marc_export
> file, but when I use the -i flag, I don´t get the marc records that
> have located URIs, Dyrcona told me that "the -i option to include item
> information excludes records without copies." but it should include
> the records with located URIs.
>
> Thanks.
>
> Regards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1350916/+subscriptions
>

Dan Wells (dbw2) wrote :

Looks good to me, and seems to work as advertised. Pushed to master. Thanks, Jason!

Changed in evergreen:
assignee: nobody → Dan Wells (dbw2)
status: Triaged → Fix Committed
assignee: Dan Wells (dbw2) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers